Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82923 - Main Menu->System Settings->Login Screen only uses GDM
Summary: Main Menu->System Settings->Login Screen only uses GDM
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-menus
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 15:49 UTC by Josiah Royse
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-28 17:40:24 UTC


Attachments (Terms of Use)

Description Josiah Royse 2003-01-28 15:49:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
The Main Menu->System Settings->Login Screen field only uses the
"gnome-gdmsetup.desktop" link/file instead of "kde-kdm.desktop" when
/etc/sysconfig/desktop is equal to "KDE".  

Note: you can get to the KDM configuration from under the Kcontrol panel- but
since the name "Login Screen" is nondescript, a KDE user may assume it will
launch KDM.


Version-Release number of selected component (if applicable):

kdebase-3.1-0.14, redhat-menus-0.33-1

How reproducible:
Always

Steps to Reproduce:
1.Choose Main Menu->System Settings->Login Screen
2.
3.
    

Actual Results:  GDMsetup

Expected Results:  KDM config using kde-kdm.desktop: Exec=kcmshell System/kdm


Additional info:

Comment 1 Havoc Pennington 2003-01-28 17:40:24 UTC
If you change the *dm, you're basically on your own.
Making the .desktop file a "symlink" causes some problems, such as 
making StartupNotify=true in the .desktop file break. I don't want to propagate
htmlview-style hacks.

If we eventually do a real framework for selecting "preferred applications"
then it would cover this, but in the meantime I don't expect to 
address the issue. So closing as a standalone bug, but if we do a 
preferred applications framework that spans gnome/kde we would address
it in that context (and also the email/office/web apps that are on the panel 
by default, etc. would be easy to change)

Thanks


Note You need to log in before you can comment on or make changes to this bug.