Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82912 - Xterm in RH8.0 has problems displaying output from user programs
Summary: Xterm in RH8.0 has problems displaying output from user programs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xterm-color
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 14:15 UTC by xaferfe
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 19:44:13 UTC


Attachments (Terms of Use)

Description Trond Eivind Glomsrød 2003-01-28 14:15:59 UTC
Duron 1200 MHz, SiS chipset (upgraded since phobe2 kept hardlocking - 8.0 runs
stable).

Comment 1 xaferfe 2003-01-28 14:16:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
 When you run a program if the output line isn't terminated by a \n then the
prompt from the next line wipes out the program output. only the last parts of
the output are visible. This is a bummer if you wish to use programs that have
already been written. Problem springs up with almost any type of code: C, Perl,
bash, ruby scripts. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
make a new perl file say a.pl

2.
enter command say:

print "happy muchos machos biggos";

and save the file

3.
open a new xterm and then run the program like say
perl a.pl
    

Actual Results:  The expected output is like this:
[user@localhost]perl a.pl
happy muchos machos biggos[user@localhost]

But the actual output is like:
[user@localhost]perl a.pl
[user@localhost]hos biggos





Expected Results:  The prompt seems to overwrite and erase out most of the 
output. If the string is shorter than the prompt nothing appears
on screen

Additional info:

Works with most prints that don't automagically include a \n 
to the string. So python print and ruby puts don't have this bug. 
But print from Perl and echo from bash have this problem. 
It works straight from Xterm, and the error can also be found on 
gnome-terminal and konsole

Comment 2 Miloslav Trmac 2003-01-28 16:22:12 UTC
Duplicate of 74383

Comment 3 Elliot Lee 2004-08-23 19:44:13 UTC
Closing bugs for old packages that have no maintainer.

Comment 4 Elliot Lee 2004-08-23 19:48:26 UTC
Closing bugs for old packages that have no maintainer.


Note You need to log in before you can comment on or make changes to this bug.