Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82900 - NIS domainname upper/lower case mismatch
Summary: NIS domainname upper/lower case mismatch
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypbind
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 09:21 UTC by Maarten van Gelder
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 13:00:45 UTC


Attachments (Terms of Use)

Description Maarten van Gelder 2003-01-28 09:21:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
We have a NIS server running with NIS domain name KVI (upper case).
During the installation of RedHat 8.0 on a NIS client I typed the NIS domain 
name (KVI) in capitals.
After installation in the reboot the NIS server lookup failed.

The information in /etc/yp.conf and also from 'nisdomainname' showed the domain 
name as 'kvi'. Whereas the file /etc/sysconfig/network showed 'KVI'.

After using 'authconfig' (without changing anything) the domain name was set to 
upper case and the NIS server was found.

But after a reboot the same problem arouse: NIS server lookup failed, because 
of the lower/upper case mismatch.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just reboot
2.
3.
    

Actual Results:  see description field

Expected Results:  Keep the original upper/lower case NIS domain name.

Additional info:

Why does the RH8.0 'system' convert the NIS domain name to lower case during 
the boot (but not everywhere)?
The NIS domain name is case sensitive (see the RFC)!

Comment 1 Mihai Ibanescu 2003-01-28 12:59:34 UTC
Reassigning to a more appropriate component, this issue has nothing to do with RHN.

Comment 2 Maarten van Gelder 2003-02-19 13:00:45 UTC
While browsing through the system files I found a dhclient lease file that 
showed the NIS domain name in lower case. Indeed our DHCP server returned that 
option. After changing the DHCP configuration NIS domain option to upper case 
the problem vanished.

I suppose RedHat 8.0 takes the NIS domain name from DHCP whereas the previous 
versions we use (6.2 and 7.1) take the name typed in during installation.

RedHat 8.0 installation still asks for the NIS domain although DHCP is used.
So I didn't find out the changes directly ...



Note You need to log in before you can comment on or make changes to this bug.