Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82898 - Mode 4 of function ReadKey broken in RedHat 8
Summary: Mode 4 of function ReadKey broken in RedHat 8
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl-TermReadKey
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 08:59 UTC by Need Real Name
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 07:23:28 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-28 08:59:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; compaq)

Description of problem:
Term::Readkey v2.21
Installed the tar ball from CPAN.

Window Mgr : KDE (but same problem when running in level 3 ...

When using ReadKey Mode 4 (RAW), the software doesn't detect any
key stroke anymore. Same problem with mode 3 ...

This used to work on RedHat 7.3 with same version of Term::ReadKey.

Contacted the maintainer of the software, who indicates that this is a bug in 
ReadHat 8 as the same software runs perfectly well on other distributions...



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Term::Readkey v2.21 from CPAN
2.Run the little program :

use Term::ReadKey;
	ReadMode 4; # Turn off controls keys
	while (not defined ($key = ReadKey(-1)) {
		# No key yet
	}
	print "Get key $key\n";
	ReadMode 0; # Reset tty mode before exiting


    

Actual Results:  The program loops forever, as no key is detected.

Expected Results:  program should print the depressed key.

Additional info:

Comment 1 Warren Togami 2005-05-28 07:23:28 UTC
Closing due to lack of activity and likely fixed in modern perl.  If this is
still an issue in RHEL4, FC3 or FC4 please open a new bug with new test
information and exact versions of packages.


Note You need to log in before you can comment on or make changes to this bug.