Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82897 - Segmentation fault when using gcc to compile nagios
Summary: Segmentation fault when using gcc to compile nagios
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 08:25 UTC by Need Real Name
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 19:41:14 UTC


Attachments (Terms of Use)
Attachment as requested (deleted)
2003-02-17 19:49 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-01-28 08:25:36 UTC
Description of problem:
When installing nagios-1.0 and running make all, I get a segmentation fault 
error message. The system is up2date with all recent patches.

Version-Release number of selected component (if applicable):
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)


How reproducible:
Every time

Steps to Reproduce:
1. Download nagios-1.0 and extract
2. Create /usr/local/nagios
3. adduser nagios
4. cd <nagios-1.0-extraction-dir>
5. ./configure
6. make all
    
Actual results:
[root@tux nagios-1.0]# ./configure

<----snip---->

Creating sample config files in sample-config/ ...


*** Configuration summary for nagios 1.0 11-24-2002 ***:

 General Options:
 -------------------------
        Nagios executable:  nagios
        Nagios user/group:  nagios,nagios
       Command user/group:  nagios,nagios
            Embedded Perl:  no
        Install ${prefix}:  /usr/local/nagios
                Lock file:  ${prefix}/var/nagios.lock
           Init directory:  /etc/rc.d/init.d

 Web Interface Options:
 ------------------------
                 HTML URL:  http://localhost/nagios/
                  CGI URL:  http://localhost/nagios/cgi-bin/
 Traceroute (used by WAP):  /usr/sbin/traceroute

 External Data Routines:
 ------------------------
              Status data:  Default (text file)
              Object data:  Template-based (text file)
             Comment data:  Default (text file)
            Downtime data:  Default (text file)
           Retention data:  Default (text file)
          Peformance data:  Default (external commands)
       Extended info data:  Template-based (text file)


Review the options above for accuracy.  If they look okay,
type 'make all' to compile the main program and CGIs.

[root@tux nagios-1.0]# make all
cd ./base && make
make[1]: Entering directory `/home/software/linux-apps/nagios/nagios-1.0/base'
gcc -g -O2 -DHAVE_CONFIG_H -DNSCORE   -c -o checks.o checks.c
gcc -g -O2 -DHAVE_CONFIG_H -DNSCORE   -c -o config.o config.c
config.c: In function `read_main_config_file':
config.c:1102: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [config.o] Error 1
make[1]: Leaving directory `/home/software/linux-apps/nagios/nagios-1.0/base'
make: *** [all] Error 2


Expected results:


Additional info:
[root@tux nagios-1.0]# uname -a
Linux tux.birkbeck.org.uk 2.4.18-19.8.0 #1 Thu Dec 12 04:37:40 EST 2002 i686 
athlon i386 GNU/Linux

Comment 1 Jakub Jelinek 2003-02-17 14:49:41 UTC
Is it reproduceable, always same ICE on the same file/line?
If yes, please attach preprocessed source (config.i;
created by gcc -save-temps -g -O2 -DHAVE_CONFIG_H -DNSCORE   -c -o config.o config.c 
).

Comment 2 Need Real Name 2003-02-17 19:49:10 UTC
Created attachment 90138 [details]
Attachment as requested

Preprocessed source as requested. Yes - the error is reproducable.

Comment 3 Jakub Jelinek 2003-02-18 12:44:36 UTC
Are you able to reproduce it on this file (ie. does it segfault
if you run gcc -g -O2 -S config.i)?
Cannot reproduce it here (tried gcc-3.2-7, gcc-3.2.1-1 and gcc-3.2.2-1).


Note You need to log in before you can comment on or make changes to this bug.