Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82892 - http URI support (IPP) broken
Summary: http URI support (IPP) broken
Keywords:
Status: CLOSED DUPLICATE of bug 120690
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-printer
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 100796 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 06:24 UTC by Chris Ricker
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-08 14:46:29 UTC


Attachments (Terms of Use)

Description Chris Ricker 2003-01-28 06:24:14 UTC
cups has support for the IPP printing protocol, which I've been using on older
versions of RHL with the following /etc/cups/printers.conf configuration file:

[root@winsucks root]# more printers.conf 
# Printer configuration file for CUPS v1.1.15
# Written by cupsd on Thu 10 Oct 2002 05:57:21 PM GMT
<DefaultPrinter phaser860>
Info phaser860
DeviceURI http://phaser860.example.com:80/ipp/
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
[root@winsucks root]# 

When I try this on beta4 (either fresh install or upgrade from 8.0), I get:

Can't understand DeviceURI: http://phaser860.example.com:80/ipp/

Comment 1 Tim Waugh 2003-01-28 09:49:59 UTC
This is coming from redhat-config-printer, which doesn't have support for this
type of URI yet.  The queue will still work, however; you'll just have to manage
it from the browser interface rather than the configuration tool.

The IPP screen on the config tool needs a 'specify URL' bit I guess.

Comment 2 Chris Ricker 2003-01-28 14:20:34 UTC
Okay. Then I guess the most pressing problem is that I have a valid cups
configuration, yet every time I start cups, redhat-config-printer is spewing
errors on the screen (ie, even if r-c-printer isn't immediately extended to
support IPP configuration, which I wouldn't really expect given current
deadlines etc., it really does need to recognize that existing IPP configs are
in fact valid). That's different than previous releases, where IPP w/ cups Just
Worked b/c r-c-printer wasn't involved....

Comment 3 Tim Waugh 2003-01-28 17:03:52 UTC
Yep, fixed in CVS.

Comment 4 Tim Waugh 2003-01-29 17:52:02 UTC
0.6.43-1.

Changing to DEFERRED (for when I actually teach the tool about that URI scheme).

Comment 5 Tim Waugh 2003-07-28 10:01:08 UTC
*** Bug 100796 has been marked as a duplicate of this bug. ***

Comment 6 Tim Waugh 2004-12-08 14:46:29 UTC

*** This bug has been marked as a duplicate of 120690 ***


Note You need to log in before you can comment on or make changes to this bug.