Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82872 - fails upgrading from 8.0 - cant handle partition table
Summary: fails upgrading from 8.0 - cant handle partition table
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-28 00:06 UTC by Chris Ricker
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-25 15:25:35 UTC


Attachments (Terms of Use)

Description Chris Ricker 2003-01-28 00:06:57 UTC
I have several machines with the following drive in them:

[root@winsucks root]# hdparm -i /dev/hda

/dev/hda:

 Model=SAMSUNG SV2001H, FwRev=QN100-07, SerialNo=0399J1DRA16750
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=38997, SectSize=619, ECCbytes=4
 BuffType=DualPortCache, BuffSize=1945kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=39179952
 IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: ATA/ATAPI-6 T13 1410D revision 1:  1 2 3 4 5 6

[root@winsucks root]# 

On the first of these machines which I tried upgrading from 8.0 to beta4, I got
an error message:

"partition table of unexpected type loop for your arch"

I was only able to install beta4 by re-initializing the partition table and
doing a fresh install. Upgrading was not an option.

Comment 1 Jeremy Katz 2003-01-28 05:40:14 UTC
That's from parted, but if you've blown it away, there's a good chance that
there's not much more that can be done for it now :/

Comment 2 Chris Ricker 2003-01-28 05:56:43 UTC
I've still got a room full of the machines running 8.0, so if it's at all
reproducible I should be able to do so ;-)

Comment 3 Matt Wilson 2003-02-04 04:28:04 UTC
can you reproduce this and make sure to get the partition table off the drive
with "dd if=/dev/hda of=bs.bin count=2048 count=1" ?


Comment 4 Matt Wilson 2003-02-11 05:46:16 UTC
any luck?


Comment 5 Chris Ricker 2003-02-11 06:13:04 UTC
I'll try to reproduce it when I'm back in town from this business trip....

Comment 6 Michael Fulbright 2003-02-13 17:24:57 UTC
Thanks.

Comment 7 Matt Wilson 2003-02-19 04:56:22 UTC
any luck?


Comment 8 Chris Ricker 2003-02-19 20:46:37 UTC
I'll get back next Wed or Thursday (maybe later if we have more @#$% snow like I
encountered trying to get to Boston ;-)

Comment 9 Michael Fulbright 2003-04-22 16:18:04 UTC
Any luck?

Comment 10 Chris Ricker 2003-04-25 13:07:05 UTC
I just tried on another one of the machines -- it upgraded successfully

Comment 11 Chris Ricker 2003-04-25 15:25:35 UTC
I'm going to close this out. I can't reproduce it on the two boxes I've tried,
so there's not a lot you can do about whatever might have caused it the first
time....


Note You need to log in before you can comment on or make changes to this bug.