Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82868 - Digital USB-connected camera Kodak EasyShare CX4300 not detected
Summary: Digital USB-connected camera Kodak EasyShare CX4300 not detected
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 22:59 UTC by Simen E. Sandberg
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 22:59:01 UTC


Attachments (Terms of Use)

Description Simen E. Sandberg 2003-01-27 22:59:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Kernel: 2.4.20-2.24 i686
Red Hat Linux release 8.0.93 (Phoebe)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start computer
2. Plug in digital camera
3. Turn on digital camera

    

Actual Results:
usb.c: USB device 3 (vend/prod 0x40a/0x566) is not claimed by any active driver.
(from dmesg)

Expected Results:  Should be detected so gphoto2 (manually updated) could access
it. This worked fine with the latest 7.3-kernel, but not with 2.4.20-2.24.

Additional info:

The version of gphoto2 that is included can not access this camera, but version
2.1.1 can. This worked perfectly with 7.3, but not in this version.

Comment 1 Pete Zaitcev 2003-02-03 21:43:47 UTC
Just in case, please do "ps aux| grep khubd" with the failing case.
The 2.4.20-2.24 should have the fix which practically disabled whole
USB in first Phoebe, but let's be sure.

Also, I would like /proc/bus/usb/devices attached to the bug.

The last thing, please never say "latest 7.3 kernel", that's not very
useful when we have uncertainties. I need actual version (2.4.18-19.7.x,
for instance) to reduce the uncertainty. In other words, this is what
I'll use to run diff -ur. It probably cannot be fixed now, but all the same...
Thought to let you know.


Comment 2 Simen E. Sandberg 2003-02-03 22:59:01 UTC
I'm terribly sorry... When I had gathered the information you requested, I just
downloaded and reinstalled gphoto2 once more, and everything suddenly worked!
This should not be a bug at all. I'm sorry I reported it. The real bug is bug
81663, closed/wontfix. 

I still get the same error messages, but that is not a bug if Gphoto2 can access
the camera. I probably got the same error messages with 2.4.18-7.x (yes, it was
that version), but since it worked, I didn't notice.


Note You need to log in before you can comment on or make changes to this bug.