Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82859 - routing issues with multiple nics in same subnet.
Summary: routing issues with multiple nics in same subnet.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: net-tools
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 20:18 UTC by Chris Kloiber
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-29 11:18:54 UTC


Attachments (Terms of Use)
host file (deleted)
2003-01-28 13:52 UTC, John Cotter
no flags Details
ifcfg for eth0 (deleted)
2003-01-28 13:53 UTC, John Cotter
no flags Details
ifcfg for eth1 (deleted)
2003-01-28 13:54 UTC, John Cotter
no flags Details
ifcfg for eth2 (deleted)
2003-01-28 13:55 UTC, John Cotter
no flags Details
network file (deleted)
2003-01-28 13:55 UTC, John Cotter
no flags Details
route -n output (deleted)
2003-01-28 13:56 UTC, John Cotter
no flags Details

Description Chris Kloiber 2003-01-27 20:18:09 UTC
Description of problem:

A customer's large Oracle server (10 nics, 2 onboard and 2- 4 port cards) 
He can use both eth0 and eth1 (the onboard cards) on the same network
(172.13.36.0) but add any of the others and this problem occurs.

I verified I see the same problem using single 4 port card on my 7.2 Alpha at
home. When more than 2 nics are configured in the same subnet, all of the cards
in that subnet stop working and the route -n looks like:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.21.36.0     0.0.0.0         255.255.255.0   U     0      0        0 eth2
172.21.36.0     0.0.0.0         255.255.255.0   U     0      0        0 eth2
172.21.36.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
172.21.36.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         172.21.36.1     0.0.0.0         UG    0      0        0 eth1

I currently don't have the hardware to test this in 8.x

Comment 1 John Cotter 2003-01-28 13:52:11 UTC
Created attachment 89639 [details]
host file

Comment 2 John Cotter 2003-01-28 13:53:51 UTC
Created attachment 89640 [details]
ifcfg for eth0

Comment 3 John Cotter 2003-01-28 13:54:35 UTC
Created attachment 89641 [details]
ifcfg for eth1

Comment 4 John Cotter 2003-01-28 13:55:04 UTC
Created attachment 89642 [details]
ifcfg for eth2

Comment 5 John Cotter 2003-01-28 13:55:42 UTC
Created attachment 89643 [details]
network file

Comment 6 John Cotter 2003-01-28 13:56:56 UTC
Created attachment 89644 [details]
route -n output

Comment 7 Phil Knirsch 2003-01-28 13:59:33 UTC
Well, for one, the GATEWAY in the network file is wrong. It should read:

GATEWAY=172.21.36.1

although i doubt that this is the source of the problem.

Unfortunately i don't have the hardware here either to reproduce the problem, so
until i have this bug will have to wait.

Read ya, Phil


Comment 8 Radek Vokal 2005-03-29 11:18:54 UTC
If this bug still persists please reopen. Otherwise I'm closing this with WONTFIX


Note You need to log in before you can comment on or make changes to this bug.