Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82850 - kernel contains incomplete swsusp patch
Summary: kernel contains incomplete swsusp patch
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 18:06 UTC by Dan Berger
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-05 14:21:13 UTC


Attachments (Terms of Use)

Description Dan Berger 2003-01-27 18:06:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

Description of problem:
The swsusp patch that's been applied to the RH kernel sources is incomplete, and
causes a build failure if CONFIG_SOFTWARE_SUSPEND is enabled.

Also - since the patch has already been (badly) applied, it's not possible
(easy, anyway) to re-apply it correctly.  Specifically, Drivers/ide/ide-disk.c
hasn't been patched with the needed suspend/resume functions.

$ uname -a
Linux walkabout 2.4.18-19.8.0 #1 Thu Dec 12 05:39:29 EST 2002 i686 i686 i386
GNU/Linux

$ rpm -q kernel-source
kernel-source-2.4.18-19.8.0

$ grep SOFTWARE_SUSPEND /usr/src/linux-2.4/.config
CONFIG_SOFTWARE_SUSPEND=y



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. enable CONFIG_SOFTWARE_SUSPEND in your kernel config 
2. attempt to build the kernel
3. observe the build (link) failure
   

Additional info:

Comment 1 Dan Berger 2003-01-27 18:58:49 UTC
I should probably also mention that I generated my config by copying
configs/kernel-2.4.18-i686.config, and only changed that particular parameter
(CONFIG_SOFTWARE_SUSPEND).

It's also interesting to note that taking the shipped config, running make
xconfig, and immediately saving the configuration (making no changes) results in
a very different config file.

Comment 2 Dan Berger 2003-01-27 19:39:50 UTC
it looks like the patch is being applied as part of patch-2.4.19-rc1-ac1(.bz2) -
and that it's complete in that patch - I'm not yet sure where/how it's getting
snarfed, but I'll post anything I find here.

Comment 3 Dan Berger 2003-01-27 19:45:02 UTC
got it - looks like it's being unapplied by linux-2.4.18-idebackport.patch -
which was diff'ed against the CVS HEAD.


Comment 4 Alan Cox 2003-06-05 14:21:13 UTC
We don't plan to do anything with software suspend support at this time.


Comment 5 Dan Berger 2003-06-05 14:53:03 UTC
I don't suppose you could remove the partially applied patch so folks who want
to do something with software suspend have a fighting chance?

Comment 6 Arjan van de Ven 2003-06-05 15:11:23 UTC
current errata kernels no longer have it

Comment 7 Dan Berger 2003-06-05 16:13:19 UTC
excellent, thanks for the info.


Note You need to log in before you can comment on or make changes to this bug.