Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82846 - can't use SSL through RHN Proxy Server
Summary: can't use SSL through RHN Proxy Server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rhn_register
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 17:10 UTC by Steve Bonneville
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-05 14:13:09 UTC


Attachments (Terms of Use)
tethereal output (deleted)
2003-01-27 17:12 UTC, Steve Bonneville
no flags Details

Description Steve Bonneville 2003-01-27 17:10:43 UTC
Description of problem:

When trying to use rhn_register to register an Advanced Server client through
a RHN Proxy Server, can not use SSL because rhn_register is too old and no
errata is available.  Non-SSL connections from the client to the Proxy Server work.

Version-Release number of selected component (if applicable):

Tested with rhn_register-2.7.9-7.x.2 and the rhn-proxy-1.1-62 ISO for AS.
Documentation with the rhn-proxy-1.1-62 ISO specifies that I need to have at
least rhn_register-2.7.11-? on the clients for this to work (RHN-proxy-IC.pdf
guide, page 44), but the errata package doesn't seem to be available for AS2.1.
The rhns-ca-cert-1.0-1.noarch.rpm built by my proxy server is installed on the
client.  Both proxy server and client used AS2.1.

How reproducible: Always.  :)

It looks like the sslCACert directive in /etc/sysconfig/rhn/rhn_register is not
honored by this version of rhn_register.    Tethereal output is attached,
station3 is the Proxy Server and station4 is the client.

Connection through the proxy server does not work with these settings in the
client's /etc/sysconfig/rhn/rhn_register file:

  serverURL=https://station3.example.com/XMLRPC
  sslCACert=/usr/share/rhn/RHNS-CORP-CA-CERT

but it does work with:

  serverURL=http://station3.example.com/XMLRPC

Comment 1 Steve Bonneville 2003-01-27 17:12:48 UTC
Created attachment 89621 [details]
tethereal output

Comment 2 Steve Bonneville 2003-09-05 14:13:09 UTC
Works with rhn_register-2.8.34-1.2.1AS.  Closing bug.


Note You need to log in before you can comment on or make changes to this bug.