Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82834 - Creating routes with static-routes doesn't work
Summary: Creating routes with static-routes doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 74320
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 15:42 UTC by Simon Matter
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:26 UTC


Attachments (Terms of Use)

Description Simon Matter 2003-01-27 15:42:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.2.22-6.2.3 i686)

Description of problem:
I want to create a static route and have put this into
/etc/sysconfig/static-routes:
eth0 net 10.0.0.0 netmask 255.0.0.0 gw 10.1.0.254

It simply doesn't work. While looking at the code, I'm wondering how it should
work but the docs in /usr/share/doc/initscripts-6.95/sysconfig.txt tell me that
what I'm trying to do is correct.

What is the correct way to define static routes now?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure eth0 with 10.1.0.123/16
2. create static route in /etc/sysconfig/static-routes
3. reboot (or do appropriate steps...)
    

Actual Results:  no static route has been added to the routing table

Expected Results:  a static route should have been added

Additional info:

Comment 1 Bill Nottingham 2003-01-27 17:47:05 UTC

*** This bug has been marked as a duplicate of 74320 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.