Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82829 - Attribute Error NoneType
Summary: Attribute Error NoneType
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dateconfig
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 14:49 UTC by techsupport
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:26 UTC


Attachments (Terms of Use)

Description techsupport 2003-01-27 14:49:06 UTC
Description of problem:

When running dateconfig (redhat-config-date) in a terminal window the following 
erro is returned:

[root@popeye root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in 
__init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in 
setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'


Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Run dateconfig (redhat-date-config) in a terminal window.
2.
3.
    
Actual results:
The following error is returned:

[root@popeye root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in 
__init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in 
setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'


Expected results:
The date/time configuration window should initialize.

Additional info:
This system is also running squid, firestarter and apache webserver.

Comment 1 Brent Fox 2003-01-27 19:38:05 UTC

*** This bug has been marked as a duplicate of 76313 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.