Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8282 - Amanda package is unusable, I made a new one
Summary: Amanda package is unusable, I made a new one
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: amanda
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-07 22:13 UTC by Marc MERLIN
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-27 18:57:43 UTC


Attachments (Terms of Use)
add dependency on inetd, clean rpmsave rename, fix upgrade issues (deleted)
2000-03-07 23:30 UTC, Marc MERLIN
no flags Details | Diff

Description Marc MERLIN 2000-01-07 22:13:36 UTC
After spending too long trying to get the powertools amanda package to
work, I realized that because of how it was misbuilt, there was no way
to use it, so I made new packages using ideas from the debian packages

You can find the new packages here:
http://updates.valinux.com/html/6.1.2-up/AByName.html

Comment 1 Tim Powers 2000-01-07 22:48:59 UTC
The amanda package you were working with is not the same package in the
Powertools 6.1 tree, are you sure that you are using the correct package? The
source package in powertools is amanda-2.4.1p1-3.src.rpm, which source did you
have problems with? I looked at your changelog and I didn't see my changelog
entries in there, the correct 6.1 package should work fine. It is available form
here:

ftp://ftp.redhat.com/redhat/powertools/6.1/

Tim

Comment 2 Marc MERLIN 2000-01-07 23:27:59 UTC
Mmmh, I must have grabbed the amanda from powertools 6.0.
I looked at your package but the differences are minimal (%defattr and
STATFS_SCALE patch).

Are you saying that you are actually using the powertools amanda package and
that it works for you? If so, please accept my apologies wrt to my comments
in the changelog of my spec file, but do let me know that it can somehow be
made to work out of the box.
If you can make it work with the help of some suitable configuration file
(which one can't guess since they're not included in the package), the configure
line still has several problems.
You are missing at least
--localstatedir=/var/lib
--with-gnutar-listdir=/var/lib/amanda/gnutar-lists
--with-smbclient=/usr/bin/smbclient
--with-gnutar=/bin/tar (see spec file for comments)

I've made many other modifications, but the best thing is probably for you to
pull my src.rpm and look at the spec file (it contains among other things
a working set of sample config files, a quick setup readme file, and a bunch
of other files that amanda needs in order to work)
ftp://ftp.valinux.com/pub/software/VALinux/updates/source/amanda-2.4.1-8.src.rpm

Comment 3 Tim Powers 2000-01-13 01:31:59 UTC
fixed in rawhide

Comment 4 Marc MERLIN 2000-03-02 01:59:59 UTC
This is probably not an package bug, but every time HJ Lu upgrades his machine
to the latest 6.1.9x, the upgrade or the inetd package botches /etc/inetd.conf
and removes
amanda    dgram  udp wait    operator.disk /usr/sbin/tcpd
/usr/lib/amanda/amandad
amandaidx stream tcp nowait  operator.disk /usr/sbin/tcpd
/usr/lib/amanda/amindexd
amidxtape stream tcp nowait  operator.disk /usr/sbin/tcpd
/usr/lib/amanda/amidxtaped

I haven't looked very closely at what is responsible for this problem.
I also noticed that the first version of that package was missing a line that
moved /etc/inetd.conf_amanda_server.sav to /tmp, but apparently that got fixed
later

Comment 5 Tim Powers 2000-03-02 02:12:59 UTC
This is actually the ddefault behavior of RPM when dealing with config files
where the md5 sum is different from the origional package (in this case inetd).
Saved config files aren't moved into /tmp, they are renamed in their current
directories to someting like <filename>.rpmsave

I am closing this because it is not a bug with amanda, but is expected behavior
WRT how RPM backs up changed config files.

Comment 6 Marc MERLIN 2000-03-07 23:26:59 UTC
(for those reading the bug on bugzilla, this was a misunderstanding, Tim and me
agreed on a course of action for future versions of amanda).

The problem with disappearing lines in inetd.conf is due to the unexpected
behavior from RPM, and the attached spec file diff works around this, as well
as cleans up the inetd.conf_amanda_{server,client}.rpmsave issue.
(I understand that this will get fixed at a later date)

Comment 7 Marc MERLIN 2000-03-07 23:30:59 UTC
Created attachment 147 [details]
add dependency on inetd, clean rpmsave rename, fix upgrade issues

Comment 8 Marc MERLIN 2000-04-07 20:48:59 UTC
I forgot to include a file in the amanda-client RPM:
/usr/lib/amanda/chg-zd-mtx


Note You need to log in before you can comment on or make changes to this bug.