Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82797 - Error on firstboot, cannot set date/time now
Summary: Error on firstboot, cannot set date/time now
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-26 18:35 UTC by Todd Booher
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:25 UTC


Attachments (Terms of Use)
Traceback log file on first boot (deleted)
2003-01-26 18:36 UTC, Todd Booher
no flags Details

Description Todd Booher 2003-01-26 18:35:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
On first boot after a clean install of phoebe beta 2 I received
the following trace back:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Now whenever I try to set the date or time in gnome it does nothing after
clicking on "Adjust Date & Time".  This happens either when I'm logged in as
root or a normal user.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login in as root
2. Right click on the date/time applet on the taskbar
3. Click on "adjust date & time"
    

Actual Results:  Nothing happens

Expected Results:  Date/Time applet should open to adjust those settings.

Additional info:

Comment 1 Todd Booher 2003-01-26 18:36:21 UTC
Created attachment 89609 [details]
Traceback log file on first boot

Comment 2 Brent Fox 2003-01-27 19:34:33 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.