Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82795 - reboot/shutdown fails at netfs for NFS-based system
Summary: reboot/shutdown fails at netfs for NFS-based system
Keywords:
Status: CLOSED DUPLICATE of bug 63602
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-26 16:16 UTC by Oliver Scheck
Modified: 2014-03-17 02:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:25 UTC


Attachments (Terms of Use)
Patch for rc: disable usage of locale (deleted)
2003-01-26 16:19 UTC, Oliver Scheck
no flags Details | Diff
Patch for netfs: disable usage of locale, ignore NFS / (deleted)
2003-01-26 16:24 UTC, Oliver Scheck
no flags Details | Diff
nfs umounts: use nohup/bg when calling fuser -mk (deleted)
2003-03-31 05:33 UTC, Vilius Puidokas
no flags Details | Diff

Description Oliver Scheck 2003-01-26 16:16:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2) Gecko/20021203

Description of problem:
Both /usr and / are mounted from an NFS server.

At reboot or shutdown the script netfs fails because both rc and netfs
are still using /usr and are therefore killed by netfs itself.
rc and netfs use the following files from /usr:

/usr/lib/gconv/gconv-modules.cache
/usr/lib/gconv/ISO8859-1.so
/usr/lib/locale/locale-archive

Disabling usage of locales for these scripts solve the problem (see
patches for rc and netfs).

Furthermore netfs incorrectly tries also to umount the NFS / filesystem instead
of explicitely leaving it mounted (see patch for netfs).

Version-Release number of selected component (if applicable):
initscripts-6.95-1

How reproducible:
Always

Steps to Reproduce:
1. Rebuild linux kernel for root filesystem on NFS
2. Mount / and /usr from an NFS server
3. Shutdown or reboot the system
    

Actual Results:  netfs kills processes using /usr (rc and netfs use /usr):

INIT: no more processes left in this runlevel


Expected Results:  Unmounting of NFS filesystems and proper system reboot/shutdown.

Additional info:

Comment 1 Oliver Scheck 2003-01-26 16:19:29 UTC
Created attachment 89607 [details]
Patch for rc: disable usage of locale

Comment 2 Oliver Scheck 2003-01-26 16:24:17 UTC
Created attachment 89608 [details]
Patch for netfs: disable usage of locale, ignore NFS /

Comment 3 Vilius Puidokas 2003-03-31 05:33:25 UTC
Created attachment 90797 [details]
nfs umounts: use nohup/bg when calling fuser -mk

 if your nfs mount is so badly hosed that any process trying to access mounted
dir hangs in a D state, netfs hangs itself by calling fuser.
 fix: send fuser -mk to background; system is left with extra 3 hanging fuser
processes, but continues to do down.
 reason to user nohup, in interactive shell (netfs called manually) hanging
fuser probably will stay attached to your terminal which is not a very good
thing.

Comment 4 Bill Nottingham 2003-09-04 01:57:42 UTC
The first two patches break locale in general for  messages, which is not good.
The third is the same problem in bug #63602.

*** This bug has been marked as a duplicate of 63602 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:51:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.