Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82768 - after updates I now get this error. to a file i never ever touched /usr/lib/gcc-lib/i386-redhat-linux/3.2/include/stddef.h:201: syntax error before "typedef"
Summary: after updates I now get this error. to a file i never ever touched /usr/lib/g...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-26 03:10 UTC by 3356ka
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 19:39:25 UTC


Attachments (Terms of Use)

Description 3356ka 2003-01-26 03:10:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I get this error when I compile my program that depends on this file

/usr/lib/gcc-lib/i386-redhat-linux/3.2/include/stddef.h:201: syntax error before
"typedef"

My files are sound its stddef.h that has an issue how do i fix.


2 friends of mine also have the same issue after they updated with auto update.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH8
2.Run the auto update that does internet updates
3.Try to compile anyuthing that requires sttdef
    

Actual Results:  I'm told error can't compile 

/usr/lib/gcc-lib/i386-redhat-linux/3.2/include/stddef.h:201: syntax error before
"typedef"


Expected Results:  a clean make!

Additional info:

Comment 1 Jakub Jelinek 2003-01-26 21:48:17 UTC
Cannot reproduce (and stddef.h has not changed BTW).
Do you see it even with say
echo '#include <stddef.h>' | gcc -c -xc - -o /tmp/test.o
?
If not, can you post what is the minimal way you are able to reproduce it with?
Also, -dD dump would be very useful.

Comment 2 Jakub Jelinek 2004-10-03 19:39:25 UTC
No feedback, closing.


Note You need to log in before you can comment on or make changes to this bug.