Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82763 - ImageMagick sends for help with Netscape to a bad URL
Summary: ImageMagick sends for help with Netscape to a bad URL
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-26 01:55 UTC by Michal Jaegermann
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-16 04:49:23 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2003-01-26 01:55:48 UTC
Description of problem:

An attempt to "Browse Documentation" in ImageMagick "Help" menu brings
first "Unable ..." alert and after that _always_ Netscape, regardles of
any other configurations, with a bad URL
http://www.imagemagick.org/ImageMagick/ and "404 Not Found" error.
This "missing" documentation is actually available on local disk in two
separate locations /usr/X11R6/share/ImageMagick and 
/usr/share/doc/ImageMagick-5.4.3.11/ which differ only like that:

Only in /usr/X11R6/share/ImageMagick: Copyright.txt
Only in /usr/X11R6/share/ImageMagick: QuickStart.txt
Only in /usr/share/doc/ImageMagick-5.4.3.11/: README.txt
Only in /usr/X11R6/share/ImageMagick: colors.mgk
Only in /usr/X11R6/share/ImageMagick: delegates.mgk
Only in /usr/X11R6/share/ImageMagick: magic.mgk
Only in /usr/X11R6/share/ImageMagick: modules.mgk
Only in /usr/X11R6/share/ImageMagick: type-ghostscript.mgk
Only in /usr/X11R6/share/ImageMagick: type-solaris.mgk
Only in /usr/X11R6/share/ImageMagick: type-windows.mgk
Only in /usr/X11R6/share/ImageMagick: type.mgk
Only in /usr/share/doc/ImageMagick-5.4.3.11/www/Magick++: COPYING

There are no problems with browsing documents on a disk once one
knows that they are there although some internal cross-references are
broken.  For example, from
file:/usr/share/doc/ImageMagick-5.4.3.11/www/display.html
one is sent to
file:/usr/share/doc/ImageMagick-5.4.3.11/www/imagemagick.html
while only
file:/usr/share/doc/ImageMagick-5.4.3.11/www/ImageMagick.html
exist.

Version-Release number of selected component (if applicable):
ImageMagick-5.4.3.11

How reproducible:
Always

Comment 1 Matthias Clasen 2005-04-16 04:49:23 UTC
Seems to be fixed in newer packages.


Note You need to log in before you can comment on or make changes to this bug.