Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82758 - rhn update removed matching icons for mozilla, evolution etc.
Summary: rhn update removed matching icons for mozilla, evolution etc.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-artwork
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-26 00:52 UTC by Daniel Resare
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-27 19:56:57 UTC


Attachments (Terms of Use)

Description Daniel Resare 2003-01-26 00:52:46 UTC
Description of problem:

I just ran up2date on my phoebe2 installation and rebooted (new kernel). When I
logged in again the icons in the panel represetnting mozilla, evolution and OOo
writer had changed from their nice new integrated redhat look to their old look
from the respective project. (mozilla the lizard, round button evolution, OOo paper)

The old icons are also in nautilus.

Version-Release number of selected component (if applicable):

the rhn upgrade did lots of stuff. Here are a few that might be involved

gnome-panel-2.1.90.1-4
nautilus-2.2.0-1
redhat-artwork-0.61-1

Comment 1 Havoc Pennington 2003-01-26 02:30:16 UTC
Alex did you change anything?

Daniel - does changing icon theme in the Theme control panel do anything?

Comment 2 Daniel Resare 2003-01-26 10:44:32 UTC
The icon theme changes the icons on the desktop, but nothing more that I can see.

After some experimenting I have found that downgrading gnome-icon-theme from
1.0.0-1 to 0.1.5-1 fixes the problem.

Comment 3 Nathan G. Grennan 2003-01-26 12:48:28 UTC
Please keep it the way it is. I prefer the gnome icon theme to use standard
icons instead of Bluecurve icons. I have my icon theme in the theme selector and
was pleasently suprirsed to see the change.

Comment 4 Havoc Pennington 2003-01-26 15:26:39 UTC
The gnome icon theme is intended to have the gnome icons.

As I understand it the issue here is that the Bluecurve icon theme 
doesn't have the Bluecurve icons.

Thinking about it more this is probably the thing jrb tracked down, that
Bluecurve inherits from the GNOME theme and installs the Bluecurve panel icons
to the default theme. So, moving to redhat-artwork.
(The reason upgrading gnome-icon-theme broke it is because now the GNOME theme
overrides those icons so people can get the old icons in the GNOME theme.)


Comment 5 Alexander Larsson 2003-01-27 16:16:59 UTC
Ah, yeah. Thats probably it. And i think jrb fixed it in redhat-artwork. Not
sure he built a version with the fix though.


Comment 6 Havoc Pennington 2003-01-27 19:56:57 UTC
redhat-artwork 0.62 should contain the fix.

Comment 7 Daniel Resare 2003-01-29 10:50:51 UTC
I can confirm that I no longer see the problem with redhat-artwork-0.62 and
gnome-icon-theme-1.0.0-1

thanks


Note You need to log in before you can comment on or make changes to this bug.