Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82757 - ps cannot see all process
Summary: ps cannot see all process
Keywords:
Status: CLOSED DUPLICATE of bug 77780
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL: http://80.206.230.6/ps.html
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-26 00:33 UTC by Need Real Name
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:24 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-26 00:33:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
chkrootkit ( www.chkrootkit.org ) give me this response:

Checking `lkm'... You have    13 process hidden for ps command
Warning: Possible LKM Trojan installed

The hidden process seems to be related to nautilus (examining /proc/PID missing
in ps output).

It *seems* to me a bug in ps, instead of a lkm trojan on my box.

If i run chkrootkit in init 3, it doesn't find any hidden process.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Running gnome
2.Running ps
3.Check /proc (chkrootkit does it automatically)
    

Actual Results:  ps doesn't see every process

Additional info:

Comment 1 Alexander Larsson 2003-01-27 16:11:58 UTC

*** This bug has been marked as a duplicate of 77780 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.