Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82745 - Installer hangs when booting the kernel on Toshiba laptop
Summary: Installer hangs when booting the kernel on Toshiba laptop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-25 17:57 UTC by Yufeng Wei
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version: RedHat 9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-23 16:28:54 UTC


Attachments (Terms of Use)

Description Yufeng Wei 2003-01-25 17:57:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am trying to install RH 8.0 on a brandnew Toshiba Satellite 2430-S255 
laptop. After booting from the installer CD, it hangs at "Uncompressing 
Linux... Ok, booting the kernel". I tried the following options, but all hangs 
at the same place:

boot: ENTER
boot: expert
boot: linux nopcmcia nousb
boot: linux noprobe
boot: linux skipddc
boot: text
boot: expert ide2=0x170,0x376
(the ide entry was obtained from WinXP device manager)

I also used RH 7.3 and RH 7.2 installer CDs to boot, they gave only blank 
screen after boot. However, the RH 7.2 System Administrator's Survival CD can 
boot normally.

The system doesn't come with a buildin floppy drive, so I cannot try to boot 
from floppy disk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load the CD in the modular DVD-ROM/CD-RW drive, reboot the computer
2. Press F12 to select boot from DVD/CDROM
3. At "boot" enter the aforesaid options
    

Actual Results:  the installer hangs at "Uncompressing Linux... Ok, booting 
the kernel"

Additional info:

Pentium-4M 2.4GHz, 512M RAM, 40G HD, WindowsXP on the fist 20G HD, modular DVD-
ROM/CD-RW drive, no floppy.

Comment 1 Jeremy Katz 2003-01-29 21:54:45 UTC
Does the Phoebe beta we recently released work better?

Comment 2 Yufeng Wei 2003-01-30 00:05:40 UTC
I recently tried to boot from Phoebe installer CD, and it gave me the same 
result (hangs at "Ok, booting the kernel").

Comment 3 Martin Voss 2003-02-20 12:39:46 UTC
I've the same problem on my Toshiba 2430-101. It seems to be an APIC problem.

When booting the system with option noapic, the system hangs but when I compile 
a new kernel without APIC the notebook will start.

RedHat 7.0 an 7.1 starts install on this notebook.

Duncan Rubinger has found a way to install :
http://linux.toshiba-dme.co.jp/ML/tlinux-users/3000/3048.html
http://linux.toshiba-dme.co.jp/ML/tlinux-users/3000/3067.html

But i don't know, how to build a new install CD :(


Comment 4 David Wilson 2003-04-16 01:45:30 UTC
Same laptop, same problem here. Updating boot floppy vmlinuz file with
vmlinuz-2.4.20-1.1963BOOT from rawhide allows kernel to boot but modules in the
initrd.img file do not work (trying to do nfs install). Is there a set of new
floppy images with this kernel and matching initrd.img available - the rawhide
images directory for 8.0 is empty. Here in Australia the 2430 ships with a USB
floppy drive so no problem using floppy images.

What BIOS have the other 2430 users tried? The laptop here has v1.10 while the
USA web site says that v1.20 was the inital release for this laptop (and v1.30
was released only 4 days after v1.20).

Comment 5 David Wilson 2003-04-16 23:59:00 UTC
Upgrading 2430 BIOS to v1.30 (latest on Toshiba's USA and Australian sites) does
not fix this problem.

Comment 6 David Wilson 2003-04-22 00:57:57 UTC
Installed RedHat Linux 9 on this laptop with no problems.
I guess you can mark this one as resolved in current release.
Why is this bug still NEW rather than ASSIGNED to someone?

Comment 7 Yufeng Wei 2003-04-23 16:28:54 UTC
I successfully installed RedHat 9 without problems. Change status to resolved.


Note You need to log in before you can comment on or make changes to this bug.