Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82740 - extraneous ^H in emacs man
Summary: extraneous ^H in emacs man
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: groff
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-25 16:33 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 13:33:31 UTC


Attachments (Terms of Use)

Description Jay Berkenbilt 2003-01-25 16:33:38 UTC
Description of problem:

When running M-x man in emacs, resulting pages display with extraneous ^H
(backspace) characters embedded.  I'm not sure whether this is an emacs problem
or a man problem, but a similar bug in the past ended up being a problem with
/usr/share/misc/man.config.

Version-Release number of selected component (if applicable):

emacs 21.2 or later (happens with current emacs beta)
man-1.5k-2
groff-1.18.1-7

How reproducible:

always

Steps to Reproduce:
1. M-x man rpm RET
    
Actual results:

^H is visible

Expected results:

Output should be clean.

Additional info:

M-x man rpm and M-x man mkisofs both exhibit this problem.  M-x ls does not. 
Perhaps that can provide some clue as to what groff output is not getting
interpreted correctly.

Comment 1 Eido Inoue 2003-01-29 18:03:41 UTC
^H does not appear to be in the source... looks like a groff problem.

Comment 2 Tim Waugh 2003-02-06 09:43:21 UTC
Seems fixed now.  Several groff/less/... man page display bugs have been fixed
in the mean time.

Do you still see this problem?

Comment 3 Jay Turner 2003-02-10 13:33:31 UTC
I'm no longer seeing this with the latest packages.


Note You need to log in before you can comment on or make changes to this bug.