Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82719 - estimated install time way off
Summary: estimated install time way off
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-25 07:13 UTC by John Mellor
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:23 UTC


Attachments (Terms of Use)

Description John Mellor 2003-01-25 07:13:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
The estimated install time should remain fairly constant after a few packages
have been installed, and fairly accurately reflect the estimated installation time.

In the observed case, the installation estimated time for 618 packages ballooned
from an initial 13 minutes to just under 35 minutes.  The estimation code is
obviously broken.

Possible unhandled calculation factors: 1GHz athlon, 512MB pc133 SDRAM, 4GB ATA
disk with slow transfer rate of ~3MB/s (per hdparm timings), 56xCDRW.  Also
noted that postinstall script runtimes incorrectly do not seem to be factored
into the calculation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install product
 

Actual Results:  Product correctly installed in over twice the calculated time
estimate.

Expected Results:  Actual install time should closely match the expected time.

Additional info:

Comment 1 Michael Fulbright 2003-01-27 16:56:08 UTC

*** This bug has been marked as a duplicate of 81479 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.