Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82715 - gnumeric hangs on a search (F7)
Summary: gnumeric hangs on a search (F7)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnumeric
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-25 06:36 UTC by Christopher Stone
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 21:35:36 UTC


Attachments (Terms of Use)

Description Christopher Stone 2003-01-25 06:36:20 UTC
Description of problem:  Performing a search in gnumeric causes it to hang.
Version-Release number of selected component (if applicable): gnumeric-1.0.12-1
How reproducible: press F7 in gnumeric.

Comment 1 Havoc Pennington 2003-01-25 16:22:24 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=104407

Comment 2 Havoc Pennington 2003-01-25 17:15:20 UTC
Jody says it works for him - does it matter what document you have open?
Other ideas on how to reproduce?

Comment 3 Christopher Stone 2003-01-25 19:53:26 UTC
hrm, I'm assuming it works for you as well?  All I can think of, is that this is
an upgrade from Phoenix, and I am running KDE as my window manager.  I can try
running in GNOME and see if that helps at all, but it worked fine in Phoenix
under KDE.  It may also be a side-effect of the font problem?  You don't have to
load up any document, just run gnumeric and press F7.  I will report back if it
successfully works under GNOME.

Comment 4 Christopher Stone 2003-01-25 20:00:00 UTC
locks up under GNOME as well.

Comment 5 Christopher Stone 2003-01-25 20:17:37 UTC
I ran an strace on it and it looks like it hanging on a futex:

futex(0x42125028, FUTEX_WAKE, 2147483647, NULL) = 0
futex(0x42127d84, FUTEX_WAIT, 1, NULL

Comment 6 Havoc Pennington 2003-01-25 20:43:14 UTC
Oh, we had a problem like this before, that was fixed by upgrading glibc/kernel.
I remember now. Though it was "hangs on startup" before.

Are you using phoebe 1? Can you try phoebe 2?

Comment 7 Christopher Stone 2003-01-25 20:55:16 UTC
I'm using Red Hat Linux release 8.0.93 (Phoebe), which I think is the 2nd
edition because the 1st version didn't even install for me.

Comment 8 Havoc Pennington 2003-02-03 22:38:05 UTC
glibc 2.3.1-40 fixes this problem for me.

Comment 9 Christopher Stone 2003-02-03 23:04:29 UTC
HI, thanks for the info.  Is this rpm available for download somewhere?  I would
like to compile my own version of gnumeric 1.1.16 (which I would also like to
see in Phoebe, the README says it is stable).

Comment 10 Christopher Stone 2003-02-03 23:22:23 UTC
nevermind, found the rpms in rawhide.  Still want to cast a vote for seeing
devel version of gnumeric in Phoebe though :)

Comment 11 Christopher Stone 2003-02-04 04:55:02 UTC
I installed the latest glibc from rawhide and it did not fix this bug for me.

Comment 12 Havoc Pennington 2003-02-04 07:35:00 UTC
What version did you install? "rpm -q glibc"

If it isn't -40 then you need to install a newer one to test.

Comment 13 Christopher Stone 2003-02-04 19:38:36 UTC
I installed the following RPMs from rawhide:

binutils-2.13.90.0.16-7
glibc-debug-2.3.1-40
glibc-utils-2.3.1-40
glibc-2.3.1-40
glibc-profile-2.3.1-40
glibc-common-2.3.1-40
glibc-devel-2.3.1-40
gnumeric-1.0.12-2

with these RPMs installed, I still get the lock-up when I press F7 in gnumeric.

Comment 14 Christopher Stone 2003-02-04 19:41:51 UTC
Oh, and I also installed

glibc-kernheaders-2.4-8.7
and I used the i686 build of glibc.

Comment 15 Christopher Stone 2003-02-20 21:28:49 UTC
fixed with phoebe beta3.  thanks.  please mark bug as closed.

Comment 16 Havoc Pennington 2003-02-20 21:35:36 UTC
thanks


Note You need to log in before you can comment on or make changes to this bug.