Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82714 - rc.d script does not handle version keywork correctly
Summary: rc.d script does not handle version keywork correctly
Keywords:
Status: CLOSED DUPLICATE of bug 82713
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-25 06:32 UTC by John Mellor
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:23 UTC


Attachments (Terms of Use)

Description John Mellor 2003-01-25 06:32:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
Older NTP servers and peers not using the latest NTP protocol (such as almost
all SCO unix sites) must be specified using the version keyword.  This keyword
is being passed through the firewall punching code in /etc/rc.d/init.d/ntp
script, causing a failed firewall rule attempt for "version".

For example, from my /etc/ntp.conf:

    server xenitec.xenitec.on.ca version 2

is perfectly legal, but incorrectly parsed in 2 identically coded places in the
ntp startup script (start and stop functions).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use an ntp.conf with a version keyword
    

Expected Results:  keywords after the servername should be parsed out and ignored.

Additional info:

Comment 1 John Mellor 2003-01-25 06:36:17 UTC
bug 82713 (not punching peers through the firewall) should also handle
additional keywords the same way as the server keyword needs to do.

Comment 2 John Mellor 2003-02-23 04:04:10 UTC
Still not fixed in Phoebe 3 release.

Suggested code fix:

replace the sed script assignment of timeserver (2 places) with:

timeservers=`/usr/bin/awk '$1=="peer"||$1=="server"{print $2}' $ntpconf`

This change also fixes bug 82713 correctly.

Comment 3 Harald Hoyer 2003-03-10 14:50:48 UTC

*** This bug has been marked as a duplicate of 82713 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.