Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82712 - crash assumes ntpserver configured
Summary: crash assumes ntpserver configured
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-25 05:52 UTC by John Mellor
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:23 UTC


Attachments (Terms of Use)

Description John Mellor 2003-01-25 05:52:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
After a full fresh install of Phoebe 2 beta, NTP information was never requested
during installation, but is assumed and not checked in firstboot.  This causes
the attached firstboot traceback due to null reference. 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Full install of Phoebe 2, custom setup, default packages plus the RH config
packages
2.First time coming up, firstboot is run, causing the fault

    

Actual Results:  traceback, followed by firstboot aborting that step and
continuing on.

Expected Results:  no traceback

Additional info:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Comment 1 Warren Togami 2003-01-25 06:54:48 UTC
Was this a text install?  Hard Drive, CDROM, NFS, FTP, HTTP?


Comment 2 Warren Togami 2003-01-25 06:55:14 UTC
Boot floppy or cdrom boot?


Comment 3 Brent Fox 2003-01-25 17:10:21 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.