Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82704 - Menus not displaying text
Summary: Menus not displaying text
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL: http://dennis.homelinux.net/openoffic...
Whiteboard:
: 83307 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-25 01:02 UTC by Dennis Gilmore
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 04:43:25 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2003-01-25 01:02:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030105

Description of problem:
The menus all have no text.  this is a clean kickstart installed system. 
Whenever i open a menu i get no text.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open openoffice
2.
3.
    

Actual Results:  no text in menus

Expected Results:  Menus to display the text for them

Additional info:

Comment 1 Warren Togami 2003-01-31 10:21:03 UTC
I can reproduce this 100% only within a VNC session.  Xvnc lacks XRENDER, but
other X servers without XRENDER that I have tested do not exhibit this problem.

What X server do you use and see this problem, or which video card running on
Phoebe2?

Comment 2 Dennis Gilmore 2003-02-02 02:59:06 UTC
I am using stock 8.0.93 install  no updates the machine is an IBM Personal
Computer 300GL, PII 233, 160Mb ram, it has an onboard Cirrus logic GD 5465
chipset.  X is 4.2.99.3-20030115.0

Comment 3 Dennis Gilmore 2003-02-02 03:06:05 UTC
On a further note. i just tried exporting my display to my main desktop which is
running 8.0 with a radeon 700 card running X 4.2.0-72 and i dont get the problem
with the same build of openoffice.  so im thinking its a X bug,  not a OO bug. i
will file a bug for X

Comment 4 Warren Togami 2003-02-02 03:24:12 UTC
I disagree, OpenOffice fails to display text in most menus with certain X
servers, including Xvnc and your particular controller.  This indicates to me
that OpenOffice isn't properly doing something.


Comment 5 Dennis Gilmore 2003-02-02 03:48:39 UTC
Ok then.  What is it then that is causing menus not to display?  is it that OO
is calling a function provided only by a certain part of X  that not all drivers
support (definetly an OOo bug).  or is it that the call to X is not implemented
correctly in all the X drivers(an X bug)?  on a side note what is bug 79578 
that this bug blocks?

Comment 6 Warren Togami 2003-02-02 05:10:28 UTC
Can you please test the build from OpenOffice.org to see if it has the same problem?

ftp://videl.ics.hawaii.edu/mirrors/openoffice/stable/1.0.2
Install it into a different location like /opt/openoffice, wipe out your
~/.openoffice and ~/.sversionrc and run it.  Does it exhibit the same problem?

Do you have StarOffice 6.0 to test too?

Also what version of Red Hat's openoffice are you running?  Try the latest 1.0.2
packages from Rawhide too.

I earlier had a theory that this problem had to do with the lack of XRENDER in
Xvnc, however all other XRENDERLess servers (X-Win 5.0, Solaris 9 update 2
openwin, etc.) that I have tested work properly with Phoebe's openoffice.  Thus
I have no idea what could be causing this.

Comment 7 Dennis Gilmore 2003-02-02 05:41:11 UTC
Fixed in 1.0.2 from rawhide. must have been a bug with 1.0.1  fixed in 1.0.2
Warren have you tried at your end with 1.0.2?  do you still get the same?

Comment 8 Warren Togami 2003-02-02 09:23:37 UTC
Confirmed, 1.0.2 works in Xvnc,  however it introduces 2 or 3 other unrelated
behaviors that were not in 1.0.1.  I will investigate this and file if they
aren't already filed.


Comment 9 Mike A. Harris 2003-02-03 05:59:37 UTC
*** Bug 83307 has been marked as a duplicate of this bug. ***

Comment 10 Mike A. Harris 2003-02-03 06:47:14 UTC
Sounds like cirrus color expansion is shot.  Try adding to the device
section of the config file XaaNoCpuToScreenColorExpandFill

Comment 11 Warren Togami 2003-02-03 07:06:57 UTC
OpenOffice 1.0.2 no longer exhibits this problem with both the Cirrus and Xvnc.

1) Want us to downgrade to 1.0.1?
2) Can I do anything similar to isolate this bug in Xvnc?


Comment 12 Dennis Gilmore 2003-02-03 10:27:49 UTC
I downgraded back to 1.0.1 and added option "XaaNoCpuToScreenColorExpandFill" to
the devices section of the X config file and the menus displayed as expected. 
Perhaps if this is a comon problem on the cirrus chipset it should be a default
option.  

Comment 13 Bill Nottingham 2003-02-18 00:18:59 UTC
OOo bug fixed, reassigning to X.

Comment 14 Mike A. Harris 2003-02-18 08:23:30 UTC
dennis) No, please don't downgrade to 1.0.1, as that is not what we will be
shipping.  I don't want to disable video hardware features for a broken app
we're not shipping.  I want to know what is wrong with the driver if you
use the latest software that is in our current lineup.

Warren states that he is not having this problem with OOo 1.0.2, so I am
not convinced what the right thing is to do.  Also recently some bugs
have been fixed in X that are related to drawing fonts (color expansion).

I don't mind disabling CpuToScreenColorExpandFill, or attempting to fix it,
but only if I really have to, and only on the chips it is reported buggy
in while using the absolute latest XFree86 builds.

Can you upgrade to the latest everything and if the problem persists, 
attach your X server log and config file.  Then try adding Option "noaccel"
to your config file.  If that works let me know.

Comment 15 Dennis Gilmore 2003-02-19 09:26:40 UTC
As i said earlier when i updated OOo to 1.0.2 without adding anything to my XFree 
config file.  but i will update everything to rawhide and see how it goes. 

Comment 16 Mike A. Harris 2003-02-20 04:43:25 UTC
Added default option "XaaNoCpuToScreenColorExpandFill" to Cards database.


Note You need to log in before you can comment on or make changes to this bug.