Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82689 - Red Hat 8.1 Beta 2 firstboot crashed at first login
Summary: Red Hat 8.1 Beta 2 firstboot crashed at first login
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-24 21:57 UTC by Thomas Chung
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:22 UTC


Attachments (Terms of Use)

Description Thomas Chung 2003-01-24 21:57:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
Since nobody reported this problem yet, I'd like to report this bug.
Just installed Red Hat Linux 8.1 Beta 2 (8.0.93).
During the first login, firstboot crashed and create a log file at
/root/firstboot.xxx

Please see additional info for content of firstboot.xxx crash log.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 8.1 beta 2 (8.0.93)
2. During the first time boot, firstboot crashes
3. A crash log file created at /root
    

Actual Results:  cat firstboot.1043443787.22
(see additional info)

Additional info:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Comment 1 Thomas Chung 2003-01-24 21:59:04 UTC
BTW, your bugzilla doesn't have "8.1" in Version field.

Comment 2 Brent Fox 2003-01-24 22:05:04 UTC
*** This bug has been marked as a duplicate of 82061 ***

*** This bug has been marked as a duplicate of 82061 ***

Comment 3 Brent Fox 2003-01-24 22:06:22 UTC
That's because it isn't called 8.1  The product needs to be set to "Red Hat
Linux Beta".  

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.