Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82671 - anaconda does not detect lack of space on upgrades
Summary: anaconda does not detect lack of space on upgrades
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-24 19:05 UTC by Mike McLean
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-25 17:41:09 UTC


Attachments (Terms of Use)
test case (deleted)
2003-01-24 21:44 UTC, Jeremy Katz
no flags Details

Description Mike McLean 2003-01-24 19:05:58 UTC
* Phoebe public beta 2
* upgrade from 7.2 minimal

1) install 7.2 minimal, use a /boot partition
2) fill up all space in /boot
3) try to upgrade to Phoebe

The upgrade proceeds and begins installing packages, only to fail on the first
package that places files in /boot (redhat-logos in my case).  When it fails, it
gives me the "There was an error installing redhat-logos-...." dialog, which is
a fatal error.  

Don't we check to see if the packages will fit before we start installing them?

Comment 2 Jeremy Katz 2003-01-24 21:43:39 UTC
I have this failing with a simple test case from the command line as well. 
Attached.

Comment 3 Jeremy Katz 2003-01-24 21:44:24 UTC
Created attachment 89591 [details]
test case

Comment 4 Jeff Johnson 2003-01-25 17:41:09 UTC
Both broken file systems and absolutely full systems
return exactly the same value in bavail, namely 0.

So the value 0 in bavail disables disk space accounting
in rpm.

WONTFIX, because it's silly and stupid to chase one exotic
value that hardly ever happens in practice, fails with adequate
strerror message that is perfectly sane and "obvious", and because
there will always be borked file systems that return bavail = 0,
and there's far too much borkage for me to run a file system black
list.

Comment 5 Mike McLean 2003-01-27 21:20:22 UTC
Additional borkage:  filesystems with <5% free space (or whatever last bit is
reserved for root only by tune2fs) also exhibit this bug.

Confirmed that when the filesystem has 'regular' free space, the Disk Space
dialog is invoked.


Note You need to log in before you can comment on or make changes to this bug.