Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82669 - scp slows to crawl when copying large files (500mB+)
Summary: scp slows to crawl when copying large files (500mB+)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: openssh
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-24 18:47 UTC by rob lojek
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-03 08:32:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Don't disable the nagle algorithm (deleted)
2005-05-24 15:19 UTC, Tomas Mraz
no flags Details | Diff

Description rob lojek 2003-01-24 18:47:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5

Description of problem:
Example machines were stock-installed with RHAS 2.1, upgraded to latest RHAS
.rpms (as of 1/20/2003) via RHN, running 2.4.9-e8 series kernels. Hardware is
compaq dl380-G2, 4 gB RAM, though we've reproduced it on different hardware,
too. Both machines are on same switch, same VLAN, both machines locked to
100-full-duplex on switch and machines. No ethernet collisions on switch or
machines.

Both machines are using on-board Intel ethernet controllers:

00:02.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)

However, the problem appears using every NIC we've tried (3com 3c996SX gig-e,
3c985 gig-e).

scp (using default RHAS config files in /etc/ssh, and no commandline options)
starts at normal rate of 8-9 mB/s, then slows to a stop after about 500 mB of
copying.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. dd if=/dev/zero of=/opt/2gB-file bs=1024 count=2M
2. scp 2gB-file <any other RHAS machine>:/opt/

    

Actual Results:  scp slows & eventually makes little/no progress

Expected Results:  consistent copy at 7-10 mB/s. All our RH 7.1 & 7.3 machines
do this.

Comment 1 Jason Olson 2004-06-28 17:58:09 UTC
Not only does the file copy slow down, but I've had files finish 
corrupt after taking more than four hours to copy. We are unable to 
copy ISO images from machine to machine because of this.

Comment 2 Tomas Mraz 2005-05-24 15:17:17 UTC
Could you try sftp? Or recompiling a newer openssh .src.rpm from Fedora?


Comment 3 Tomas Mraz 2005-05-24 15:19:15 UTC
Created attachment 114774 [details]
Don't disable the nagle algorithm

Could you compile openssh with this patch applied if it makes any difference?

Comment 4 Tomas Mraz 2005-08-03 08:32:39 UTC
No response.



Note You need to log in before you can comment on or make changes to this bug.