Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82648 - unexpected results of rpm -q --redhatprovides
Summary: unexpected results of rpm -q --redhatprovides
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmdb-redhat
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-24 13:49 UTC by Tobias Meier
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-24 15:11:27 UTC


Attachments (Terms of Use)

Description Tobias Meier 2003-01-24 13:49:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207
Phoenix/0.5

Description of problem:
hi,

root@lnxc-501.srv.mediaways.net:~ # rpm -qa | grep net-tools
net-tools-1.60-3

root@lnxc-501.srv.mediaways.net:~ # rpm -q --redhatprovides ifconfig
no package provides ifconfig

root@lnxc-501.srv.mediaways.net:~ # rpm -ql net-tools
/bin/dnsdomainname
/bin/domainname
/bin/hostname
/bin/netstat
/bin/nisdomainname
/bin/ypdomainname
/sbin/arp
/sbin/ether-wake
/sbin/ifconfig
/sbin/ipmaddr
/sbin/iptunnel
/sbin/mii-tool
/sbin/nameif
/sbin/plipconfig
/sbin/route
/sbin/slattach
[...]

this happens with varios packages. some querys gives us the correct result:

root@lnxc-501.srv.mediaways.net:~ # rpm -q --redhatprovides iptraf
iptraf-2.4.0-5







Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see description
2.
3.
    

Additional info:

Comment 1 Tim Powers 2003-01-24 15:11:27 UTC
To see what provides a file you need to provide the path, ie.:  rpm -q --redhatprovides /sbin/ifconfigThe reason you are seeing some work and some not with the way you are doing it is because some files have the same name as the package name, so this:  rpm -q --redhatprovides iptrafIs going to return "iptraf" since the package provides and requires its own package name. Make sense?Tim


Note You need to log in before you can comment on or make changes to this bug.