Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82635 - Cannot start httpd
Summary: Cannot start httpd
Keywords:
Status: CLOSED DUPLICATE of bug 83324
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-24 09:32 UTC by Gerald Teschl
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:21 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-01-24 09:32:57 UTC
Starting httpd fails with the error

[Fri Jan 24 10:25:05 2003] [error] (38)Function not implemented: Cannot create
SSLMutex file `/etc/httpd/logs/ssl_mutex.1450'

All config files are unchanged.

Comment 1 Joe Orton 2003-01-24 10:14:41 UTC
Does that file exist? If so, remove it and try starting up again.

Comment 2 Gerald Teschl 2003-01-24 10:20:08 UTC
No.

ls: /etc/httpd/logs/ssl_mutex*: No such file or directory

Comment 3 Gerald Teschl 2003-01-24 10:23:02 UTC
Just tried to remove ssl. Now I get:

[root@tomcat root]# rpm -e mod_ssl
[root@tomcat root]# rpm -V httpd
[root@tomcat root]# service httpd start
Starting httpd:                                            [FAILED]
[root@tomcat root]# cat /var/log/httpd/error_log
[Fri Jan 24 11:16:40 2003] [crit] (38)Function not implemented: mod_rewrite:
could not create rewrite_log_lock
Configuration Failed



Comment 4 Joe Orton 2003-02-12 15:38:09 UTC
Thanks for the report - the kernel version you were running turned out to be the
deciding factor, here.

*** This bug has been marked as a duplicate of 83324 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:51:21 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.