Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82605 - An nfs drive was mistaken for another.
Summary: An nfs drive was mistaken for another.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 22:43 UTC by Glen
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-11 11:17:43 UTC


Attachments (Terms of Use)

Description Glen 2003-01-23 22:43:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
We have a system which had 3 scsi raid units hooked up to it.  Each of the raid
units has a single ext3 partition on it which is exported via nfs to roughly 20
client machines.  We shut the system down to move one of the raid units to a new
machine we bought, which left it with two raid units.  When we powered the
system back on, one of the nfs drives seems to have been mistaken for the other
one by the nfs clients.

The first drive has all of our user's home directories on it.  This drive is
fine.  The second drive however has lost much of it's data and files that belong
in our users home directories are now on this second drive.

For example, lets say we had a user named joe.  The user joe's home directory
was on the first drive under /home/data1/joe.  But then there was also a
directory on the second drive under /home/data2/joe.  All of the data in this
second directory, /home/data2/joe, is gone and in it's place are hidden files
and directories like .gconf which you would find in joe's home directory.  Also
on the second drive are directories such as /home/data2/fred, which were never
there before but did exist on the first drive as /home/data1/fred.  These new
directories also contain files you'd expect to see in users home directories.

So somehow it seems the second drive was mistaken for the first drive by the nfs
clients.

One other thing, since each of our partitions has a disk label, removing one of
the raids shouldn't have caused any problems, even if the device names changed
like they tend to do after adding or removing scsi devices.  And in looking
around on the nfs server, everything seems to be in order locally.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Steve Dickson 2004-08-11 11:17:43 UTC
This seems to be fixed in later kernels 


Note You need to log in before you can comment on or make changes to this bug.