Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825940 - [virtio-win][viostor]Roll back driver for system disk,an not signed message pop up.
Summary: [virtio-win][viostor]Roll back driver for system disk,an not signed message p...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-29 07:13 UTC by Min Deng
Modified: 2012-08-30 13:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 13:22:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
not signed (deleted)
2012-05-29 07:18 UTC, Min Deng
no flags Details

Description Min Deng 2012-05-29 07:13:12 UTC
Description of problem:
After Roll back driver for system disk,an not signed message pop up.

Version-Release number of selected component (if applicable):
kernel-2.6.32-272.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.294.el6.x86_64
virtio-win-1.5.1-1.el6.noarch  
virtio-win-1.4.0-1.el6.noarch 

How reproducible:
Always

Steps to Reproduce:

1.boot up windows 2003 32 bits and install driver 1.5.1 to data disk and then restart guest if needed.Please also make sure system is virtio after restarting
2.downgrade 1.5.1 to 1.4.0 from device manager and restart driver if needed
  select device -> right click -> update driver -> ...
3.roll back driver from 1.4.0 to 1.5.1 via properties dialog.
  
Actual results:
There were two virtio disk device and please roll back their driver one by one.
For data disk  ,it works fine.
For system disk,an not signed message pops up. 

Expected results:
No improper message shows up

Additional info:
CLI and error message will upload.

The issue only occurred on system disk.
Not reproduced  installed 1.4.0 ->  upgrade to 1.5.1   -> roll back to 1.4.0
reproduced      installed 1.5.1 ->  downgrade to 1.4.0 -> roll back to 1.5.1

Comment 1 Min Deng 2012-05-29 07:18:25 UTC
Created attachment 587323 [details]
not signed

Comment 2 Min Deng 2012-05-29 07:20:32 UTC
CLI
/usr/libexec/qemu-kvm -cpu cpu64-rhel6,+x2apic,family=0xf -smp 2 -m 2G -device virtio-balloon-pci,id=balloon0 -k en-us -usb -device usb-tablet,id=tablet0 -device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -drive file=/home/win2k3-32-ide.raw,format=raw,cache=none,if=none,werror=stop,rerror=stop,id=drive-disk0,media=disk -device virtio-blk-pci,drive=drive-disk0,id=disk0,bootindex=2 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:11:11:15:33:8a -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=4,bus=pci.0 -chardev socket,server,host=0.0.0.0,port=12346,id=channel0,nowait -device virtserialport,chardev=channel0,nr=1,id=serialport.1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0 -rtc base=utc,clock=host,driftfix=slew -name winxp -spice port=5932,disable-ticketing -vga qxl -uuid `uuidgen` -monitor stdio -drive file=/home/virtio-win-1.4.0.iso,format=raw,if=none,media=cdrom,id=drive-ide0-1-0 -device ide-drive,drive=drive-ide0-1-0,id=ide-drive0,bootindex=1 -drive file=/usr/share/virtio-win/virtio-win-1.5.1.iso,media=cdrom,cache=none,werror=stop,format=raw -fda /home/virtio-win-1.5.1.vfd -drive file=diskdata.raw,if=none,format=raw,id=drive-virtio-data1,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,id=virtio-data1,drive=drive-virtio-data1 -chardev socket,id=111a,path=/tmp/monitor-2864,server,nowait -mon chardev=111a,mode=readline

Comment 4 Min Deng 2012-05-29 08:04:57 UTC
I cannot reproduce the issue on windows 2008 64/R2,thanks

Comment 5 dawu 2012-05-29 08:17:30 UTC
Tested this issue on winxp and win2k8-32,it also happened on winxp, not reproduced on win2k8-32

Comment 7 Yan Vugenfirer 2012-06-06 12:22:17 UTC
1. What's the version of the driver after rollback?

2. Please run sigverif.exe after rollback.

Comment 9 Min Deng 2012-06-21 08:28:00 UTC
(In reply to comment #7)
> 1. What's the version of the driver after rollback?
> 
  After rollback the driver is changed to 1.4.0 

> 2. Please run sigverif.exe after rollback.

 check the drivers in c:\windows\system32\drivers\viostor.sys
                     and c:\windows\OemDir\viostor.*

 Both of them passed checking

 

Thanks,
Min

Comment 10 RHEL Product and Program Management 2012-07-10 07:57:14 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 11 RHEL Product and Program Management 2012-07-11 02:03:09 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 12 Dmitry Fleytman 2012-08-22 13:22:13 UTC
I've succeeded to reproduce this problem on freshly installed Windows server 2003 with 2 virtio-blk-pci devices.
The exact scenario is following:
    Install driver 1.5.3 for both devices
    Downgrade one of the devices to 1.4.0
    Reboot
    Downgrade second device to 1.4.0
    Reboot
    Try to run driver roll back for one of the devices

The problem can't be reproduced with one device.
System warns about unsigned driver however indicates that driver properly signed after rollback.
After second downgrade, system rollback cache contains inf and cat files from driver package 1.5.3
and sys file from driver package 1.4.0 which may point out a windows driver database problem.

All driver, cat and INF files on disk are properly signed (verified with sigverify) .

This is a Windows bug and it doesn't look like there is a work-around.

Comment 13 Mike Cao 2012-08-22 15:02:31 UTC
(In reply to comment #12)
> I've succeeded to reproduce this problem on freshly installed Windows server
> 2003 with 2 virtio-blk-pci devices.
> The exact scenario is following:
>     Install driver 1.5.3 for both devices
>     Downgrade one of the devices to 1.4.0
>     Reboot
>     Downgrade second device to 1.4.0
>     Reboot
>     Try to run driver roll back for one of the devices
> 
> The problem can't be reproduced with one device.
> System warns about unsigned driver however indicates that driver properly
> signed after rollback.
> After second downgrade, system rollback cache contains inf and cat files
> from driver package 1.5.3

Hi,Dmitry 

How to check the rollback cache inf and cat files version ?

Thanks,
Mike

> and sys file from driver package 1.4.0 which may point out a windows driver
> database problem.
> 
> All driver, cat and INF files on disk are properly signed (verified with
> sigverify) .
> 
> This is a Windows bug and it doesn't look like there is a work-around.

Comment 14 Dmitry Fleytman 2012-08-30 13:03:47 UTC
Hello, Mike

Rollback files are stored at C:\WINDOWS\system32\ReinstallBackups.
One can go there and see file properties for version number.

Dmitry.


Note You need to log in before you can comment on or make changes to this bug.