Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82592 - man pages garbled
Summary: man pages garbled
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 19:17 UTC by Michael Berganski
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 21:38:22 UTC


Attachments (Terms of Use)

Description Michael Berganski 2003-01-23 19:17:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79C-SGI [en] (X11; U; IRIX 6.5 IP32)

Description of problem:
man-pages-1.35-5
man-1.5i2-0.7x.5
redhat 7.1

man  pages garbled
example:
if you have the original man page ls.1.gz  and also have a copy ls.1.gz.orig in
/usr/share/man/man1and try to run man ls
the manpage is garbled.
I notice this when I modified the man page and also kept the original.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.man  pages garbled
example:
if you have the original man page ls.1.gz  and also have a copy ls.1.gz.orig in
/usr/share/man/man1and try to run man ls
the manpage is garbled.
I notice this when I modified the man page and also kept the original.
3.
    

Actual Results:  man  pages garbled
example:
if you have the original man page ls.1.gz  and also have a copy ls.1.gz.orig in
/usr/share/man/man1and try to run man ls
the manpage is garbled.
I notice this when I modified the man page and also kept the original.

Additional info:

Comment 1 Eido Inoue 2003-02-06 20:43:30 UTC
looks like yet another groff formatting bug

Comment 2 Florian La Roche 2003-02-08 00:27:24 UTC
This must be a problem within man.

greetings,

Florian La Roche


Comment 3 Eido Inoue 2003-02-20 21:38:22 UTC
i don't think man expects to have non-man-use files in the /usr/share/man area
(often times the /usr/share area is mounted read-only, so this is a reasonable
assumption). You can workaround this problem by naming the backup file in such a
way that the left$ of each don't match.


Note You need to log in before you can comment on or make changes to this bug.