Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82586 - first boot crashes - time and date component
Summary: first boot crashes - time and date component
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 18:18 UTC by adam allen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:20 UTC


Attachments (Terms of Use)

Description adam allen 2003-01-23 18:18:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
As firstboot starts a Traceback message is produced, a short explination tells
the this is in the time_date component.

Traceback below.

redhat-config-date produces the same sort of message (also attached)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install phoebe and run first boot
2. or
3. redhat-config-date
    

Actual Results:  Traceback from firstboot

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None


Expected Results:  To be able to check and set the system time from firstboot?

Additional info:

Traceback from redhat-config-date 

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 48, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 180, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Comment 1 Brent Fox 2003-01-23 18:50:42 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.