Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82581 - PyXML has a bug that prevents proper XML parsing
Summary: PyXML has a bug that prevents proper XML parsing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: PyXML
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 17:47 UTC by ldd
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-25 22:04:52 UTC


Attachments (Terms of Use)

Description ldd 2003-01-23 17:47:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
PyXML has a bug that makes it so that handle_end_tag is not called on
application objects when an XML file is validated or parsed.  The bug has been
fixed in version 8.1 (and probably 8.0 too) of PyXML.  This was tested by
installing the 8.1 RPM found at the PyXML web site:

http://pyxml.sourceforge.net/

Note that their RPM conflicts with the 4Suite rpm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Write an application that uses xmlval or xmlproc and attempts to
    do something with closing tags.
2.  Run the application.

    

Actual Results:  handle_end_tag is never called.

Expected Results:  handle_end_tag should be called for every closing tag
encountered.

Additional info:

Sorry for the terseness of the steps above.  I'm keeping this short because the
fix is simple: upgrade to PyXML version 8.1.

Note that I see that Phoebe, like RedHat 8.0, still uses version 7.1 of PyXML.

Comment 1 ldd 2003-06-10 18:03:53 UTC
This bug is also present in RH 9.0.

Note that I made a mistake in the original bug report.  The version of PyXML
shipped is 0.7.1 and the required version is (now) 0.8.2.

I don't know why I missed the "0." at the start of the version numbers... :-/

Lest there be any doubt about this: this is a showstopper.

Comment 2 Florian La Roche 2003-06-25 22:04:52 UTC
Rawhide should soon have 0.8.2.

Thanks for the bug-report,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.