Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82573 - KPackage needs to be added to the RH 8.0 distribution
Summary: KPackage needs to be added to the RH 8.0 distribution
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kpackage
Version: 8.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 15:42 UTC by Frank Perreault
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-08 22:13:28 UTC


Attachments (Terms of Use)
Patch to build kpackage (deleted)
2004-12-08 21:56 UTC, Orion Poplawski
no flags Details | Diff

Description Frank Perreault 2003-01-23 15:42:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
RH decided in Version 8.0 to remove KPackage from the KDE install because they
created their own packaging tool.  While this new tool is fine for the user who
you want to hide system complexities from, for those of us who need to see the
details of the packages we are installing, this new tool is unsatisfactory.  

Until such time that the RH RPM tool is capable of displaying the kind of
detailed information that some of us need, the KPackage utility should be
included in the distribution.  It should also be made available for immediate
download for those of us needing KPackage's functionality now but can't wait for
RH tool to be tweaked.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 8.0
2.
3.
    

Additional info:

Comment 1 Bill Nottingham 2003-02-20 04:54:55 UTC
This was done intentionally; redhat-config-packages is what we're supporting in
the future.

Comment 2 Frank Perreault 2003-02-20 05:26:29 UTC
As I mentioned in my second paragraph, until such a time when Redhat's new tool
is capable of supplying all the functionality that we are had with KPackage, the
KPackage tool should be included in the distribution.  To be blunt, the current
Redhat package tool in the 8.0 release is a poor excuse for a package manager. 
No detailed information about the packages you are installing and no way to use
the tool to install RPM's that aren't part of the 8.0 release.  We shoould be
moving forward, not backward.

Comment 3 Orion Poplawski 2004-12-08 21:56:49 UTC
Created attachment 108153 [details]
Patch to build kpackage

To help things along - here's a patch to the current kdeadmin spec file to
build kpackage.

Comment 4 Ngo Than 2004-12-08 22:13:28 UTC
if you want to have kpackage again, please rebuild it. sorry,
redhat-config-package is what we are supporting in the future.


Note You need to log in before you can comment on or make changes to this bug.