Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82564 - ncurses-5.3-1 breaks colors in mutt and lynx
Summary: ncurses-5.3-1 breaks colors in mutt and lynx
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL:
Whiteboard:
: 82498 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-23 14:11 UTC by Olivier Baudron
Modified: 2015-01-08 00:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 17:32:26 UTC


Attachments (Terms of Use)

Description Olivier Baudron 2003-01-23 14:11:16 UTC
After the upgrade of ncurses from 5.2-29 to 5.3-1, mutt and lynx don't display
colors anymore.

Comment 1 Thomas E. Dickey 2003-01-23 19:37:32 UTC
some issue with the patches Redhat makes to the terminfo file (5.3 has the same color behavior as 5.2, with/without wide-character support).  But I haven't seen the "5.3-1" rpm.

Comment 2 Eido Inoue 2003-01-23 19:40:26 UTC
5.3-1 unfortunately did not patch the terminfo src for our xterm so it would
include color. accepting and fixing.

Comment 3 Eido Inoue 2003-01-23 19:58:55 UTC
*** Bug 82498 has been marked as a duplicate of this bug. ***

Comment 4 Sammy 2003-01-29 19:19:02 UTC
Same problems with ncurses-5.3-2. 
 
Also, downgrading to ncurses-5.2 of Phoebe leaves dangling symlinks to libcurses.so 
and libcurses.so.5. Needless to say no ncurses bases application works until the  
symlinks are recreated by hand. 

Comment 5 Eido Inoue 2003-01-31 20:27:36 UTC
xterm-redhat entry has been added to ncurses-5.3-3, which should fix the colors.

Comment 6 Jay Turner 2003-02-03 17:32:26 UTC
Fix confirmed with ncurses-5.3-3.


Note You need to log in before you can comment on or make changes to this bug.