Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825508 - [abrt] zenity-3.4.0-1.fc17: zenity_tree_dialog_response: Process /usr/bin/zenity was killed by signal 11 (SIGSEGV)
Summary: [abrt] zenity-3.4.0-1.fc17: zenity_tree_dialog_response: Process /usr/bin/zen...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: zenity
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:735e0c603c7563835852971af80...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-27 02:06 UTC by Juan
Modified: 2012-12-09 05:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-09 05:58:41 UTC


Attachments (Terms of Use)
File: dso_list (deleted)
2012-05-27 02:06 UTC, Juan
no flags Details
File: maps (deleted)
2012-05-27 02:06 UTC, Juan
no flags Details
File: backtrace (deleted)
2012-05-27 02:06 UTC, Juan
no flags Details

Description Juan 2012-05-27 02:06:05 UTC
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        zenity --list --checklist --multiple --width=530 --height=450 '--separator=\\n' '--title=BEESU: nautilus scripts manager' '--text=Select the nautilus scripts you want to install.\\nIf you want to uninstall some, uncheck them.' --column 'Install me' --column 'Script name' false 'Edit with gEdit' false 'Edit with gHex' false 'Execute/Execute Application' false 'Execute/Execute Script' false 'Files and Folders/Change File Access' false 'Files and Folders/Change File Owner' false 'Files and Folders/Delete Selected Files' false 'Files and Folders/New File Here' false 'Files and Folders/New Folder Here' false 'GNOME Shell Open' false 'Open Nautilus Here' false 'Open Terminal Here'
crash_function: zenity_tree_dialog_response
executable:     /usr/bin/zenity
kernel:         3.3.7-1.fc17.x86_64
pid:            3583
pwd:            /home/Wise
time:           Sat 26 May 2012 08:45:17 PM COT
uid:            1000
username:       Wise

backtrace:      Text file, 23567 bytes
dso_list:       Text file, 6346 bytes
maps:           Text file, 33715 bytes

build_ids:
:8b33feb27b2125997520fdd21c90c42a65e438f1
:8568e11bef79abaf14513d18a8559282d8dad34a
:54a5cc118d928470da13565de8592b664a9868e0
:647c8183274c4626c81e86e7a631a81782a04e65
:b6d75088f555d197be1476cb1c580640826ae029
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:5dd234206476b0387cd251598aa72a2c95c763c5
:301bb855a0952a10241e6d7190773fdabf23e383
:b277af36744327e3d58eae76bcdaadcca71a28c6
:7716bc5c1738194dad6ec6679d05ae3782139288
:a7a90d872ef72df12f4344a1a6fadb184e5c0cc8
:0e1267a4d81de05f053eeed7f2f61fb46cda9e7c
:9d49f2f604fdc7a787f63c16cc08353956f2fd41
:f64b7319b84d426ed547084bdb2577f4f596c18f
:710b0d8cc36603d66327090defd37c99daa38f28
:0a688bf9160e6e3a2a8f41967f3c75094bca08a7
:bd0ac043ae8788e4131de24fa2becebf2ba97698
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:e2f8ba3db2c86456528fe1f09829c62263d0fdee
:faca16f15d87b83d2947a386e319b02f724dcbb5
:e8072e89279c50bd27e7954a84f8a4aa290b6a2c
:87712be648d2d43ea4cd002fe7a859df636f1e13
:3d60535f052babb998bae4807bc992c5d15df5c4
:253afe744466fe7580bbb6040de6183dba9e2b02
:127f8958b602715234a02b88adb08afd9e34c203
:234d4eb1aa690c38533ef82f517b390255d3bc4d
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:8f7c190397d7c1f617e66f18f759714662b60367
:67792c148d2b8f13f6732c9367e926c26d7376c5
:63651cdc0224824a9c9324c77c3b5887378e871d
:c4ec0971b2dcee71aaf8374975474054245fea00
:a553a7e9625a224a8f39286909adc17787ad51bd
:e3354959e32e471066df83c93f98f33e75198697
:822e9b3523e8312240f41a25722d539bc77ed436
:73777e822e00ca152ffca281ab0ace0cb498ec48
:404cbecd24d186758ed474b345313da28b2990fa
:3f0991d9a4679b6bdd8a78ab2d05ecf4cc995651
:d804f8ee47797da9213a92f00cd095ecada8d79f
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:4d09d82785dab5f95c01b69bc0785145a5954d30
:7c35310fc506498c612d5d982ab03becc4b4817c
:9ea9b4fd0fc47b9ba19d393e1c1f70959654c6b8
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292
:731b3801f71de6bd888953161b715e6cbda0ab60
:508cf66f72e70054a41215f80ed2385c6bb80030
:fce4569ceeae1e716f4efcc2334d057a178b4e1b
:c24fd7404668fdbb57aec685a0f63cdd8a289d29
:839c8e3a55bd7f61afdcfebeae52f9dadc3a69fb
:4b044fe80e4c1b69986abc4b160c303048005d4e
:6c08d8c9f6358200131cda5c9b563545d5c806ba
:c61e487cc8906c4f1bd85b39a4d751b414e423a0
:d68cffb59ecc797b49e453165ae8145b0acdcf7a
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:617e70e4105dfaa44b8d1f53b914e37eb5886ceb
:1a0c09f270adf8398df4362ce0acfafc1f970982
:a5cf7008c28585406297cf76ce11e2e554e5a7b4
:5bf8427ddeff24a2bd36962f68e6af6ffe14970f
:247132297f287226a24c12e683292f5c94013066
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/Wise/2

core_backtrace:
:d68cffb59ecc797b49e453165ae8145b0acdcf7a 0xd0dd - [exe] -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x206d8 - libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0xf943 - libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x27d88 g_signal_emit_valist libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0xbba38 - libgtk-3.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x20003 - libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0xb9d53 - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x17adcf - libgtk-3.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0xf943 - libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x27d88 g_signal_emit_valist libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x2a2d0e - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x178d96 - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x17a9a3 gtk_main_do_event libgtk-3.so.0 -
:8b33feb27b2125997520fdd21c90c42a65e438f1 0x48e62 - libgdk-3.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x475cc g_main_context_dispatch libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x479e8 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x47de2 g_main_loop_run libglib-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x179d65 gtk_main libgtk-3.so.0 -
:d68cffb59ecc797b49e453165ae8145b0acdcf7a 0xd846 - [exe] -
:d68cffb59ecc797b49e453165ae8145b0acdcf7a 0x6ad2 - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Lotusfedora
:GIO_LAUNCHED_DESKTOP_FILE_PID=3565
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/Wise/keyring-TXrPX4/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/run/user/Wise/keyring-TXrPX4
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=Wise
:SSH_AUTH_SOCK=/run/user/Wise/keyring-TXrPX4/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1274,unix/unix:/tmp/.ICE-unix/1274
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/nautilus-beesu-manager.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/Wise/.local/bin:/home/Wise/bin
:MAIL=/var/spool/mail/Wise
:QT_IM_MODULE=xim
:PWD=/home/Wise
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GNOME_KEYRING_PID=1270
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/Wise
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:BEESU_BASE_SCRIPT_FOLDER=/home/Wise/.gnome2/nautilus-scripts/beesu
:LOGNAME=Wise
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-v7ozrJ3C5L,guid=9ddbae88181d21093637395b00000091
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/Wise
:XAUTHORITY=/var/run/gdm/auth-for-Wise-B8XWZF/database
:OLDPWD=/usr/libexec/nautilus-beesu-manager/scripts
:_=/usr/bin/zenity

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63052                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63052                63052                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:pipe:[67968]
:pos:	0
:flags:	01
:2:/home/Wise/.xsession-errors
:pos:	447416
:flags:	0102002
:3:socket:[68657]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[66844]
:pos:	0
:flags:	02004002

var_log_messages:
:May 26 20:45:17 Lotusfedora kernel: [ 2518.723454] zenity[3583]: segfault at 5e ip 000000000040d0dd sp 00007fff66e52ad0 error 4 in zenity[400000+14000]
:May 26 20:45:17 Lotusfedora abrt[3587]: Saved core dump of pid 3583 (/usr/bin/zenity) to /var/spool/abrt/ccpp-2012-05-26-20:45:17-3583 (3596288 bytes)

Comment 1 Juan 2012-05-27 02:06:11 UTC
Created attachment 587054 [details]
File: dso_list

Comment 2 Juan 2012-05-27 02:06:13 UTC
Created attachment 587055 [details]
File: maps

Comment 3 Juan 2012-05-27 02:06:15 UTC
Created attachment 587056 [details]
File: backtrace

Comment 4 Norman Smith 2012-06-02 15:54:15 UTC
zenity --list --checklist --column "Buy" --column "Item" TRUE Apples TRUE Oranges FALSE Pears FALSE Toothpaste

Run above on commandline copied straight from man page. It core dumps every time.
I just installed F17.  A bunch of my admin jobs use zenity.  They didn't work.  I re-installed zenity from Fedora repository.  No help.  I copied a zenity executable from an F16 system and so far it does not core dump.


backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 5 Jake Jackson 2012-06-03 12:12:04 UTC
copied winetricks to /usr/local/bin and executed it

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 6 Alejandro 2012-06-05 22:25:04 UTC
I was just opening winetricks

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 7 Mace Moneta 2012-06-16 20:06:30 UTC
Seeing the same segfault in my script running:

/usr/bin/zenity --height=210 --title "Exit Action" \
   --hide-header --list --radiolist --column "Select" \
   --column "Action" FALSE Suspend FALSE Restart FALSE Shutdown FALSE Logoff

Reverting to the F16 version corrected the problem for me as well.

Comment 8 u5afe 2012-07-14 10:36:33 UTC
activating  a few more beesu right click scripts

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 9 JAlberto 2012-07-15 17:32:01 UTC
i was running winetricks

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 10 Dan Kegel 2012-07-21 19:02:24 UTC
Dup of bug 811401 ?

Comment 11 ARIKO 2012-08-07 20:54:33 UTC
winetricks settings (show broken apply )

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 12 Norman Smith 2012-08-08 17:50:55 UTC
I noticed others are adding comments and backtraces to this bug report.  This may or may not be useful but I cloned the Gnome repository for zenity and found that when I compiled version 3.4 it fails consistently and that the top of the master branch (version 3.4.1) seems to handle all my scripts OK.  I think the problem is fixed upstream and all will be well with 3.4.1 when it makes it's way down.  I will run 3.4.1 and if it shows any problems I'll note it here.

Comment 13 tumbleweedterrace 2012-08-28 03:28:43 UTC
allowing bessu scrips to execute

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 14 hx 2012-09-23 10:00:56 UTC
dont remeber...

backtrace_rating: 4
Package: zenity-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 15 D. Charles Pyle 2012-09-23 12:37:09 UTC
Had just installed the Beesu package and installed scripts into Nautilus using Beesu Scripts Manager. This problem also affects Fedora 17 and Fedora 16.

backtrace_rating: 4
Package: zenity-3.4.0-2.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 16 Vadim Rutkovsky 2012-11-24 20:43:19 UTC
Can't reproduce using attached scripts in zenity.x86_64 3.6.0-1.fc18

Comment 17 Mace Moneta 2012-11-28 18:09:29 UTC
Appears to be corrected in zenity-3.4.0-2.fc17.

Comment 18 Fedora Update System 2012-11-28 23:22:47 UTC
zenity-3.4.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/zenity-3.4.0-2.fc17

Comment 19 Fedora Update System 2012-11-29 06:11:46 UTC
Package zenity-3.4.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zenity-3.4.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19348/zenity-3.4.0-2.fc17
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2012-12-09 05:58:43 UTC
zenity-3.4.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.