Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82543 - sftp kioslave double ssh hostkey warning popups
Summary: sftp kioslave double ssh hostkey warning popups
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 09:27 UTC by Warren Togami
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-06 00:15:55 UTC


Attachments (Terms of Use)

Description Warren Togami 2003-01-23 09:27:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
When you connect to a sftp:// address in Konqueror it logins via SFTP to a
remote SSH server.  If that host's sshd key isn't in your ~/.ssh/known_hosts
file it will pop-up a window asking if you want to accept that key, just like
ssh client would do.

In Phoebe2 this works properly, except it pops up two windows asking the same
thing instead of one.  I believe Phoebe1 didn't have this behavior.

Version-Release number of selected component (if applicable):
Phoebe2 kdebase-3.1-0.14

How reproducible:
Always

Steps to Reproduce:
1. Erase server host key from ~/.ssh/known_hosts.
2. Run konqueror
3. sftp://username@servername
    
Actual Results:  
Two pop-up windows.

Expected Results:  
There should be only one pop-up window.

Comment 1 Warren Togami 2003-01-23 09:35:10 UTC
Additionally, if you click "Yes" both times it adds the host key twice to
known_hosts.  This is rather improper.

Comment 2 Ngo Than 2003-02-22 22:16:43 UTC
It seems to be fixed in beta5 or later. I cannot reproduce it in this beta5

Comment 3 Warren Togami 2003-02-22 23:42:13 UTC
I still see this in latest Rawhide.


Comment 4 Warren Togami 2003-02-24 08:56:48 UTC
Arg... sometimes it causes kfmclient to segfault.


Comment 5 Warren Togami 2004-11-06 00:15:55 UTC
Seems fixed in FC3.


Note You need to log in before you can comment on or make changes to this bug.