Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82528 - Firstboot should be in chosen languages
Summary: Firstboot should be in chosen languages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard: qa-i18n
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-23 04:44 UTC by David Joo
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 20:52:42 UTC


Attachments (Terms of Use)

Description David Joo 2003-01-23 04:44:23 UTC
Description of problem:
For CJK installation, first boot is in English rather than CJK

Version-Release number of selected component (if applicable):


How reproducible:
Every installation

Steps to Reproduce:
1. Install in CJK
2. reboot
3.
    
Actual results:
Firstboot in English.

Expected results:
Firstboot in CJK

Additional info:
I believe this is caused because, when init script runs it is running in 
Enlish since we can't show CJK on the console. It would be good when firstboot 
runs, if it can grep /etc/sysconfig/i18n value and determine the locale from 
there.

Comment 1 Brent Fox 2003-01-28 21:44:33 UTC
I've tried adding ". /etc/profile.d/lang.sh" to the top of the initscript on my
test machine as notting suggested, but this had no effect.

notting: any other idea what I need to do in the initscript?  running
/usr/sbin/firstboot directly brings up Japanese just fine, so there must be
something missing in the initscript.

Comment 2 Brent Fox 2003-01-31 21:51:39 UTC
notting: any ideas here?  I'm sort of over my head in initscript land.

Comment 3 Bill Nottingham 2003-01-31 22:35:17 UTC
Fixed in CVS. What happens is that since /etc/init.d/functions sets LC_MESSAGES
to en_US, this gets inherited from /etc/rc, so we have to unset it first.


Comment 4 Brent Fox 2003-02-03 18:37:44 UTC
QA: firstboot-1.0.5-2 should contain the fix.

Comment 5 Jay Turner 2003-02-03 20:52:42 UTC
Fix confirmed with firstboot-1.0.5-2.


Note You need to log in before you can comment on or make changes to this bug.