Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825273 - subscription-manager release --set should only allow entries from --list
Summary: subscription-manager release --set should only allow entries from --list
Keywords:
Status: CLOSED DUPLICATE of bug 818205
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 771748 827225
TreeView+ depends on / blocked
 
Reported: 2012-05-25 14:13 UTC by Matt Reid
Modified: 2012-06-04 18:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-04 18:18:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Reid 2012-05-25 14:13:23 UTC
Version -
subscription-manager-1.0.2-1.git.2.2b23e6e

Right now, I can enter subscription-manager release --set=6Sever or anything at all and subscription-manager will act like its fine and understands a release of HIHOWareyou. 

Can we add logic to only allow strings that --list can output?

If they enter something wrong or misspelled, we could return a message of - "Unrecognized release, please use subscription-manager release --list to see a listing of available release versions".

Comment 1 Alex Wood 2012-06-04 18:18:54 UTC

*** This bug has been marked as a duplicate of bug 818205 ***


Note You need to log in before you can comment on or make changes to this bug.