Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82520 - Setting up an SMB printer fails with "You must choose a share, not a host"
Summary: Setting up an SMB printer fails with "You must choose a share, not a host"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 01:11 UTC by Marc Deslauriers
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-23 17:56:16 UTC


Attachments (Terms of Use)

Description Marc Deslauriers 2003-01-23 01:11:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
When trying to set up an SMB printer, I cannot use the "specify" button to set
the credentials. Here is what I'm doing:

1- Start System Settings/Printing
2- Click the "new" button
3- Click on the "forward" button
4- Leave the default name as-is, click on "forward"
5- Select "Networked Windows" from the drop down. The name of the windows
computer running winxp that's sharing the printer appears. When I click on the
arrow beside the name, nothing appears.
6- Click on the "Specify..." button
7- Fill out the appropriate information. Click on "ok". I get back to the screen
with the computer name in it. Nothing has changed.
8- Click on "Forward"
9- Get the error message "You must choose a share, not a host".







Version-Release number of selected component (if applicable):
phoebe 8.0.93

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
    

Actual Results:  Error message

Expected Results:  I would expect the share name to appear in the window after
entering the correct credentials in the "specify" button.

Additional info:

Comment 1 Tim Waugh 2003-01-23 09:29:55 UTC
So that's redhat-config-printer-0.6.35-1.

After finishing with the specify... dialog, you should have a new share listed
in the main browse screen; is it not there at all, or just not selected?

How about if you use lower-case rather than upper-case to specify the host name?

Comment 2 Marc Deslauriers 2003-01-23 12:40:47 UTC
The new share never appears under the computer name. Only the computer name
still appears in the window.

I have tried both uppercase and lowercase information to no avail.

Another machine I have with RedHat Linux 7.3 works as expected with the same share.

Comment 3 Tim Waugh 2003-01-23 14:55:23 UTC
Oh, I see it now.  Thanks for catching this.  Fixed package is
redhat-config-printer-0.6.39-1.  It will appear in rawhide in due course, but in
the mean time you can grab it from ftp://people.redhat.com/twaugh/tmp.

Comment 4 Marc Deslauriers 2003-01-23 15:21:18 UTC
I've upgraded to 0.6.39-1. Unfortunately, I still get the same thing. The share
name never appears under the computer name.


Comment 5 Tim Waugh 2003-01-23 15:25:41 UTC
If you run 'redhat-config-printer' from a terminal and try adding the printer,
do you get any output in the terminal?

Comment 6 Tim Waugh 2003-01-23 15:26:14 UTC
Oh, by the way, did you make sure to install the .i386.rpm file (not just the
.src.rpm)?

Comment 7 Marc Deslauriers 2003-01-23 15:35:49 UTC
Yeah, it's installed:
[mdeslaur@linux mdeslaur]$ rpm -q redhat-config-printer
redhat-config-printer-0.6.39-1

Here is what appears on the console just after the "Specify" dialog is filled out:

[mdeslaur@linux mdeslaur]$ redhat-config-printer
Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 822, in smb_specify_clicked
   machine, sharename = match.groups ()
AttributeError: 'NoneType' object has no attribute 'groups'


Comment 8 Tim Waugh 2003-01-23 15:46:57 UTC
Oops, please install the -gui package that I just uploaded. :-)

Comment 9 Marc Deslauriers 2003-01-23 17:54:06 UTC
Everything's working great now, thank you!



Note You need to log in before you can comment on or make changes to this bug.