Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82517 - perl doesn't know 'GB18030' encoding
Summary: perl doesn't know 'GB18030' encoding
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-23 00:33 UTC by Bernd Groh
Modified: 2014-06-18 08:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-11 10:53:39 UTC


Attachments (Terms of Use)

Description Bernd Groh 2003-01-23 00:33:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When using the module Encode and trying to convert either from or to 'GB18030',
using Encode::from_to, I'll get the message:

Unknown encoding 'GB18030'

Since I believe 'GB18030' should be supported, I thought that this might be a bug.

Regards,
Bernd


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. write following perl-script:
--
#!/usr/bin/perl
use Encode;
$string = $ARGV[0];
Encode::from_to($string, 'GB18030', 'UTF8');
print "$string\n";
--
2. make it executable and execute it


Actual Results:  Follwing Error-Message appears:
--
Unknown encoding 'GB18030' at <path to script>/<script> line 4
--

Expected Results:  The GB18030-encoded string provided as argument to the script
should have been displayed (assuming STDOUT is screen) in UTF8-encoding.

Additional info:

Comment 1 Warren Togami 2005-05-28 07:25:37 UTC
Is this still an issue in RHEL4, FC3, or FC4?

Comment 2 Warren Togami 2005-09-11 10:53:39 UTC
Closing due to lack of response and RH8 is not a supported product.


Note You need to log in before you can comment on or make changes to this bug.