Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825160 - Change network with netconsole loaded cause kernel panic
Summary: Change network with netconsole loaded cause kernel panic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 839266
Blocks: 846431
TreeView+ depends on / blocked
 
Reported: 2012-05-25 09:25 UTC by Guohua Ouyang
Modified: 2016-04-26 13:46 UTC (History)
17 users (show)

Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, changing the network configuration of the Red Hat Enterprise Virtualization Hypervisor while netconsole was enabled resulted in a kernel panic ("Kernel panic - not syncing: Watchdog detected hard LOCKUP"). This kernel bug has now been fixed. The hypervisor has been updated to include a later kernel release that does not have this bug. Changing the network configuration of the Hypervisor with netconsole enabled will not result in a kernel panic.
Clone Of:
: 839266 (view as bug list)
Environment:
Last Closed: 2013-02-28 16:34:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
kernel_panic screenshot (deleted)
2012-05-25 11:37 UTC, Guohua Ouyang
no flags Details
A trace (deleted)
2012-05-30 07:31 UTC, Fabian Deutsch
no flags Details
netconsole kernel panic (deleted)
2012-06-08 03:07 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 816034 None None None Never
Red Hat Product Errata RHBA-2013:0556 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2013-02-28 21:29:06 UTC

Internal Links: 816034

Description Guohua Ouyang 2012-05-25 09:25:59 UTC
Description of problem:
After the network is up and netconsole is loaded, try change the network, such change network from dhcp to static or configure another nic, kernel panic will happen.
on screen can see "Kernel panic - not syncing: Watchdog detected hard
LOCKUP on cpu 6".

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6

How reproducible:
100%


Steps to Reproduce:
1. Configure network up.
2. Configure netconsole.
3. Try change network, such change network from dhcp to static or configure another nic.
 
Actual results:
Kernel panic happen "Kernel panic - not syncing: Watchdog detected hard
LOCKUP on cpu 1".

Expected results:
No kernel panic happen.

Additional info:

Comment 2 Mike Burns 2012-05-25 11:05:35 UTC
Is this reproducible on RHEL?

Comment 3 Guohua Ouyang 2012-05-25 11:37:44 UTC
Created attachment 586835 [details]
kernel_panic screenshot

(In reply to comment #2)
> Is this reproducible on RHEL?

attach the screenshot firstly.

test on RHEL63 2.6.32-272.el6:
1. configure network with dhcp
2. loaded netconsole.
3. change network from dhcp to static.
4. service network restart

no kernel panic happened.

Comment 4 Mike Burns 2012-05-29 12:22:56 UTC
Any additional info on the panic?  Stack trace? core dump?  anything?

Comment 5 Fabian Deutsch 2012-05-29 16:06:14 UTC
I could not reproduce this problem with snap 5 using the followign steps:

1. Fresh install
2. Configure network up (dhcp)
3. Configure netconsole (server set to 127.0.0.1)
4. Reconfigure network to static

No kernel oops appeared (nothing on the console or dmesg)

Can you give any more details, Ouyangguohua?

Comment 8 Guohua Ouyang 2012-05-30 02:11:45 UTC
(In reply to comment #5)
> I could not reproduce this problem with snap 5 using the followign steps:
> 
> 1. Fresh install
> 2. Configure network up (dhcp)
> 3. Configure netconsole (server set to 127.0.0.1)
> 4. Reconfigure network to static
> 
> No kernel oops appeared (nothing on the console or dmesg)
> 
> Can you give any more details, Ouyangguohua?

if you specify the 127.0.0.1 as the netconsole server, does the service netconsole is loaded? I tried it here the service is not loaded. 

I think you should specify another valid server to reproduce this bug.

Comment 9 Guohua Ouyang 2012-05-30 02:17:49 UTC
(In reply to comment #4)
> Any additional info on the panic?  Stack trace? core dump?  anything?

The only thing can get is on the screen can read "Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu 6".  the screenshot is attaching in comment #3.

The screen is hang when pop-up this message, send "CAD" does not work.

Comment 10 Fabian Deutsch 2012-05-30 07:31:16 UTC
(In reply to comment #8)
> (In reply to comment #5)
> > I could not reproduce this problem with snap 5 using the followign steps:
> > 
> > 1. Fresh install
> > 2. Configure network up (dhcp)
> > 3. Configure netconsole (server set to 127.0.0.1)
> > 4. Reconfigure network to static
> > 
> > No kernel oops appeared (nothing on the console or dmesg)
> > 
> > Can you give any more details, Ouyangguohua?
> 
> if you specify the 127.0.0.1 as the netconsole server, does the service
> netconsole is loaded? I tried it here the service is not loaded. 

Now I was able to reproduce this bug:
1. Fresh install
2. Configure network (dhcp)
3. Configure netconsole (server 10.0.0.1)
4. Reconfigure network to static

You should open a second console before running the test so you can look at the trace using dmesg (run dmesg once before you raise the bug to get it into memory)

A second thing I noted was that the netconsole service seems not to be active on default: chkconfig --list netconsole only shows off

Comment 11 Fabian Deutsch 2012-05-30 07:31:57 UTC
Created attachment 587619 [details]
A trace

Comment 13 cshao 2012-06-08 03:07:06 UTC
Created attachment 590329 [details]
netconsole kernel panic

Comment 14 Guohua Ouyang 2012-06-08 03:13:54 UTC
Hi mburns,

According to comment #12, restart network service will kernel panic after configure netconsole.  This blocks registering to rhevm also if the netconsole is configured. should we bring the bug back to 6.3 or need a technical note?

Thanks,

Comment 15 cshao 2012-06-08 05:09:05 UTC
Test in RHEL6.3-20120606.3
kernel-2.6.32.278.el6.x86_64

Test result:
Restart network service will hung on "Shutting down interface eth0" after configure netconsole.

==========================
# cat /etc/issue
Red Hat Enterprise Linux Server release 6.3 (Santiago)
Kernel \r on an \m
# uname -a
Linux hp-slot6-eth0.qe.lab.eng.nay.redhat.com 2.6.32-278.el6.x86_64 #1 SMP Fri Jun 1 14:17:12 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
# /etc/init.d/netconsole status
netconsole module loaded
# /etc/init.d/network restart
Shutting down interface br0:  [ok]
Shutting down interface eth0:

Comment 18 Fabian Deutsch 2012-07-11 12:13:06 UTC
I can also reproduce this on RHEL 6.3 with kernel 2.6.32-279 :

1. Install rhel
2. Configure netconsole to point to 10.42.0.1
3. service netconsole start
4. service network restart

And fails to stop the network interfaces (like in bug #816034)

Comment 26 errata-xmlrpc 2013-02-28 16:34:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html


Note You need to log in before you can comment on or make changes to this bug.