Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825135 - Bootstrap Prerequisites
Summary: Bootstrap Prerequisites
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Clients
Version: 1.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space18
TreeView+ depends on / blocked
 
Reported: 2012-05-25 08:22 UTC by daniel.gerne
Modified: 2012-11-01 16:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-25 19:02:30 UTC


Attachments (Terms of Use)

Description daniel.gerne 2012-05-25 08:22:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Generate bootstrap script.
2. Transfer and run it on a client
3.
  
Actual results:
Missing packages rhn*

Expected results:
Register the System on Spacewalk Server.

Additional info:
Hello,

When I attempt to use the Bootstrap script after including the ActivationKey, removing the first exit-command it fails because of missing packages.
e.g. rhncfg-actions and rhn-profile-sync.
I cannot find a guide describing what exactly prerequisites a client must have before executing the bootstrap script. Are there any complete repositories for client? I found one for opensuse (client is sles) hosting the rhncfg-actions, but when I install this rpm it asks for python-xyz.
So is there any guide about the prerequisites?

thank you.

regards

Comment 1 Jan Pazdziora 2012-05-25 19:02:30 UTC
(In reply to comment #0)
> Description of problem:
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. Generate bootstrap script.
> 2. Transfer and run it on a client
> 3.
>   
> Actual results:
> Missing packages rhn*
> 
> Expected results:
> Register the System on Spacewalk Server.
> 
> Additional info:
> Hello,
> 
> When I attempt to use the Bootstrap script after including the
> ActivationKey, removing the first exit-command it fails because of missing
> packages.
> e.g. rhncfg-actions and rhn-profile-sync.
> I cannot find a guide describing what exactly prerequisites a client must
> have before executing the bootstrap script. Are there any complete
> repositories for client? I found one for opensuse (client is sles) hosting
> the rhncfg-actions, but when I install this rpm it asks for python-xyz.
> So is there any guide about the prerequisites?

You might want to start with

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Client_Configuration_Guide/index.html
http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Reference_Guide/index.html

The repositories for the client are RHN Tools channels for RHEL, or Spacewalk client repositories at

http://yum.spacewalkproject.org/1.7-client/

with documentation at

https://fedorahosted.org/spacewalk/wiki/

namely

https://fedorahosted.org/spacewalk/wiki/RegisteringClients


Note You need to log in before you can comment on or make changes to this bug.