Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 825114 - missing nodejs builder type in jenkins server
Summary: missing nodejs builder type in jenkins server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Rob Millner
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-25 07:08 UTC by Meng Bo
Modified: 2015-05-14 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-25 18:26:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2012-05-25 07:08:36 UTC
Description of problem:
create nodejs app with jenkins embedded, check the builder type from the jenkins build config page, will find the default builder type for nodejs is 'diy-0.1'.

Version-Release number of selected component (if applicable):
cartridge-jenkins-1.4-0.93.4-1.el6_2.noarch
cartridge-jenkins-client-1.4-0.27.2-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.create nodejs app with jenkins enabled.
2.go to jenkins server build page to check the configuration of this build
3.
  
Actual results:
default builder type is 'diy-0.1' and cannot find nodejs-0.6 in the list.

Expected results:
the default builder type should be same as the app type.

Additional info:
since the build can be pushed successfully, and both the app type and slave builder type are correct after push build, set the serverity as low.

no1bldr
    Framework: nodejs-0.6
     Creation: 2012-05-25T03:00:10-04:00
         UUID: 51c4cc9c869b452dbb371d885f2ef7b4
      Git URL: ssh://51c4cc9c869b452dbb371d885f2ef7b4@no1bldr-bmengdev.dev.rhcloud.com/~/git/no1bldr.git/
   Public URL: http://no1bldr-bmengdev.dev.rhcloud.com/

 Embedded: 
      None

no1
    Framework: nodejs-0.6
     Creation: 2012-05-25T02:55:13-04:00
         UUID: bd118c1b15e042628404aea4aee2cd88
      Git URL: ssh://bd118c1b15e042628404aea4aee2cd88@no1-bmengdev.dev.rhcloud.com/~/git/no1.git/
   Public URL: http://no1-bmengdev.dev.rhcloud.com/

 Embedded: 
      jenkins-client-1.4 - Job URL: https://jenkins-bmengdev.dev.rhcloud.com/job/no1-build/

Comment 1 Rob Millner 2012-05-31 00:33:27 UTC
Pull request #1 on jenkins-cloud-plugin.

Comment 2 Rob Millner 2012-06-13 21:19:19 UTC
Pull request accepted.

Comment 3 Meng Bo 2012-06-14 11:28:52 UTC
Cannot find the fix on devenv_1843, will check it on future build.

Comment 4 Meng Bo 2012-06-15 09:21:01 UTC
Verified on devenv_1846, the builder type for nodejs app exist in jenkins console now.


Note You need to log in before you can comment on or make changes to this bug.