Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82498 - ncurses-5.3 messes vim, ftp, ssh, and others
Summary: ncurses-5.3 messes vim, ftp, ssh, and others
Keywords:
Status: CLOSED DUPLICATE of bug 82564
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-22 19:44 UTC by Sammy
Modified: 2015-01-08 00:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:19 UTC


Attachments (Terms of Use)

Description Sammy 2003-01-22 19:44:06 UTC
After installing ncurses-5.3 many applications are giving errors, e.g. you cannot 
search for something in vim because some control characters are appended to 
the string being searched. In ftp the backspace has changed to ^? but it is still 
ok in konsole. ssh does not work at all. 
 
PS: When I downgraded back to ncurses-5.2 from Phoebe using rpm -Uvh --force 
      the links to libncurses.so and libncurses.so.5 were left pointing to version 5.3, 
      needless to say this required fixing by hand.

Comment 1 Thomas E. Dickey 2003-01-23 19:39:27 UTC
Redhat's 5.2 rpm package modifies ncurses' terminfo by (among other things) adding the terminfo from xterm.  I'd check first if a comparable patch was made for 5.3

Comment 2 Eido Inoue 2003-01-23 19:58:53 UTC
confirmed that indeed the color escape sequences are being output incorrectly
via vim (due to a terminfo entry being missing), but could not reproduce the
difficulty with delete/bs and ftp/ssh.

I believe the root of the problem is the same as what's described in bug #82564

*** This bug has been marked as a duplicate of 82564 ***

Comment 3 Sammy 2003-01-24 15:23:18 UTC
Sorry, I was not clear on ftp. The backspace problem happens in ftp, e.g. 
ftp to people.redhat.com and type something and try to backspace. In 
terms of ssh, I am using the non-commercial version of the real ssh and 
not openssh so that may be out of your jurisdiction. I probably have to 
rebuild that rpm with the new curses. 

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.