Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82496 - older version of gnome-python2-bonobo leaves leftover files hanging around
Summary: older version of gnome-python2-bonobo leaves leftover files hanging around
Keywords:
Status: CLOSED DUPLICATE of bug 79652
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-python2
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-22 19:35 UTC by Brent Fox
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-16 03:48:29 UTC


Attachments (Terms of Use)

Description Brent Fox 2003-01-22 19:35:43 UTC
I upgraded my workstation from 8.0 to re-0121.nightly

gnome-python2-bonobo left some files hanging around in
/usr/lib/python2.2/site-packages/bonobo

__init__.pyc and __init__.pyo

The actual python modules have moved into
/usr/lib/python2.2/site-packages/gtk-2.0/bonobo, but having the old .pyc and
.pyo files causes python to get very confused.  

For example, I start up a python interpreter and type:
import gnome.ui

and I get:
Fatal Python error: could not import bonobo.ui

It seems like gnome-python2-bonobo should make sure that the old directory is
wiped out when the package is upgraded.

Comment 1 Bill Nottingham 2003-01-24 01:49:53 UTC

*** This bug has been marked as a duplicate of 79652 ***


Note You need to log in before you can comment on or make changes to this bug.